Compatibilité Rails avec Ruby 1.8.7


#1

Bonjour à tous.

Je débarque un peu là, mais dans Rails < 2.2 il y a des problèmes de
compatibilité avec ruby 1.8.7 visiblement.

Je n’arrive pas à trouver à partir de quelle version exactement Rails
est compatible avec ruby 1.8.7, et j’ai trouvé étonnamment peu de
chose sur ce problème via google…

Y a quelques infos là :

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484351#10

qui pointe sur ces modifications là :

http://github.com/rails/rails/commit/7391f7728d96c2ec0113de57f3316c191043ad2c
http://github.com/rails/rails/commit/4e4bcb4c6b08ed392cd5576dcfc252ef574a1b88
http://github.com/rails/rails/commit/1d18651ea36e2ba274b6c2e0fd4edd425e028589
http://github.com/rails/rails/commit/0b21ac5118c293b43e5370d7a3da980514f089a2
http://github.com/rails/rails/commit/549c81db4a9ca941ea65ae2edafb0f34784f12f2
http://github.com/rails/rails/commit/f67b070facef6574df3c4386e3975242273fe456
http://github.com/rails/rails/commit/db11ef9546b1ad16cf539395b75450c1c8e9714c

Je ne maîtrise pas assez github pour savoir quelles versions de rails
incluent ces modifications ;-(
Bon par contre ces modifications datent du 1er juin, c’est déjà une
bonne info !

Je me demande en fait s’il y a pas une version de rails 2.1 voire 2.0
compatible avec ruby 1.8.7 ?

A+
Arthur


#2

Le 2 déc. 08 à 16:19, Cyril M. a écrit :

Le plus simple c’est de pas utiliser ruby 1.8.7. Enormément de monde
s’accorde à dire que cette version est une catastrophe :frowning:

Ah, j’en avais pas entendu parlé, va falloir que j’ai une discussion
avec mon administrateur debian alors ;-(

http://svn.ruby-lang.org/repos/ruby/tags/v1_8_7/NEWS


#3

Arthur Pétry wrote:

http://github.com/rails/rails/commit/f67b070facef6574df3c4386e3975242273fe456
http://github.com/rails/rails/commit/db11ef9546b1ad16cf539395b75450c1c8e9714c

Je ne maîtrise pas assez github pour savoir quelles versions de rails
incluent ces modifications ;-(
Bon par contre ces modifications datent du 1er juin, c’est déjà une
bonne info !

Je me demande en fait s’il y a pas une version de rails 2.1 voire 2.0
compatible avec ruby 1.8.7 ?

Le plus simple c’est de pas utiliser ruby 1.8.7. Enormément de monde
s’accorde à dire que cette version est une catastrophe :frowning:


Cyril M.
http://blog.shingara.fr


#4

Le mardi 02 décembre 2008 à 17:57 +0100, Nicolas Mérouze a écrit :

Le problème de Debian c’est qu’on dirait qu’ils s’en foutent
complètement de Ruby.

c’est un peu radical quand même de dire ça !

Donc 1.8.7 dans Lenny et dans les backports.

En version stable (etch) il me semblait que ruby était en version 1.8.6.
A confirmer.

Dis à ton administrateur de mettre Ruby Enterprise Edition, c’est
1.8.6 avec tous les patchs de sécurité, plus facile à installer que
compiler les sources à la main et ça inclue Rubygems.

enfin pour un admin même débutant, c’est quand même simple de compiler
ruby si besoin (./configure && make && make install)

J.


#5

Arthur Pétry a écrit :

Ah, j’en avais pas entendu parlé, va falloir que j’ai une discussion
avec mon administrateur debian alors ;-(

Les joies de Debian, ruby 1.8.5 en stable et 1.8.7 en unstable
et en testing.


Martin C. || fuse
http://www.noremember.org | http://www.synbioz.com


#6

Le problème de Debian c’est qu’on dirait qu’ils s’en foutent
complètement de
Ruby. Donc 1.8.7 dans Lenny et dans les backports.

Dis à ton administrateur de mettre Ruby Enterprise Edition, c’est 1.8.6
avec
tous les patchs de sécurité, plus facile à installer que compiler les
sources à la main et ça inclue Rubygems.

Par contre j’ai pas rencontré de problèmes particulier avec Ruby 1.8.7
et
Rails 2.1


Nicolas Mérouze


#7

2008/12/2 JD removed_email_address@domain.invalid

Donc 1.8.7 dans Lenny et dans les backports.

En version stable (etch) il me semblait que ruby était en version 1.8.6.A confirmer.

C’est Ruby 1.8.5 (d’où mon radicalisme) et non patché il me semble même.

Dis à ton administrateur de mettre Ruby Enterprise Edition, c’est 1.8.6
avec tous les patchs de sécurité, plus facile à installer que compiler les
sources à la main et ça inclue Rubygems.

enfin pour un admin même débutant, c’est quand même simple de compiler
ruby si besoin (./configure && make && make install)

Et donc là tu n’as ni readline, ni ssl. Je dis pas que c’est compliqué,
je
dis juste que REE c’est plus facile, ça inclu tout, c’est à jour (et
rubygems peut être mis à jour)… Tout l’inverse d’apt.


#8

Le 2 déc. 08 à 19:09, Nicolas Mérouze a écrit :

Dis à ton administrateur de mettre Ruby Enterprise Edition, c’est

Alors : r8ee est une horreur en 64 bits, il faut en tenir compte

Et sinon, 2 tutos pour installer du ruby 1.8.6 sous debian comme il
faut, avec ou sans mod_rails :
http://t37.net/installer-ruby-on-rails-apache-2-2-mod_fcgid-et-typo-sous-debian-etch
http://t37.net/installer-passenger-mod_rails-sous-debian

Et comme ça tu peux même installer Typo, un projet rails qu’il est
bien et qu’il est actif http://github.com/fdv/typo/commits/master (/
prosel),


Frédéric de Villamil
removed_email_address@domain.invalid tel: +33 (0)6 62 19 1337
http://t37.net Typo : http://typosphere.org


#9

Le 3 déc. 08 à 01:03, Jean-François Trân a écrit :

Le 2 décembre 2008 21:24, de Villamil Frédéric a écrit :

Alors : r8ee est une horreur en 64 bits, il faut en tenir compte

Ben faut donner alors de l’argent !

http://izumi.plan99.net/blog/index.php/2008/11/22/upcoming-ruby-enterprise-edition-improvements-thanks-to-sponsorship-campaign/

Déjà fait, sans compter mes contributions (docs, bug tracking,
support…)


Frédéric de Villamil
removed_email_address@domain.invalid tel: +33 (0)6 62 19 1337
http://t37.net Typo : http://typosphere.org


#10

Le 2 décembre 2008 21:24, de Villamil Frédéric a écrit :

Alors : r8ee est une horreur en 64 bits, il faut en tenir compte

Ben faut donner alors de l’argent !

http://izumi.plan99.net/blog/index.php/2008/11/22/upcoming-ruby-enterprise-edition-improvements-thanks-to-sponsorship-campaign/


Prochain Apéro Ruby le 11 décembre

http://twitter.com/underflow_


#11

Le problème de Debian c’est qu’on dirait qu’ils s’en foutent
complètement de
Ruby.
???

Je confirme : Etch Stable —> Ruby 1.8.5

Le 3 décembre 2008 12:15, de Villamil Frédéric removed_email_address@domain.invalid a
écrit :


#12

Le 3 déc. 08 à 23:21, Frédéric Jay a écrit :

Le problème de Debian c’est qu’on dirait qu’ils s’en foutent
complètement de Ruby.
???

Je confirme : Etch Stable —> Ruby 1.8.5

En fait le “problème” de Debian, c’est qu’ils ont un cycle de
développement et d’intégration extrêmement long. Pour un admin, c’est
le pied, parce que ça assure – en théorie, et également en pratique –
une stabilité à toute épreuve. Malheureusement pour l’utilisateur qui
a besoin de paquetages à jour, voir récents, ce n’est pas vraiment ça.

Il existe cela dit un certain nombre de paquetages plus récents
“backportés” sur la version en cours. C’est le cas pour PHP / MySQL
des paquetages dotdeb maintenus par Nexen (attention, ils forcent la
migration en MySQL en 5.1 et c’est une cata), ou simpleent des
“backports”. Il existe enfin une liste de paquetages “volatiles” avec
des cycles de release nécessairement très courts, comme les antivirus
ou les antispams.

Maintenant, évidemment, le problème, c’est qu’un paquet ruby à jour,
c’est du 1.8.7.

Backports : http://www.backports.org/dokuwiki/doku.php
Dotdeb : http://www.dotdeb.org/
Volatile : http://www.debian.org/volatile/

Mes deux cents.


Frédéric de Villamil
removed_email_address@domain.invalid tel: +33 (0)6 62 19 1337
http://t37.net Typo : http://typosphere.org


#13

Bonjour,

Noter site http://www.digiprof.fr tourne sous Rails 2.2.2, Debian Etch
et Ruby 1.8.7 patchlevel 72 compilé à partir des sources, et idem sur
nos Mac de développement. Je viens d’ailleurs de voir que sur la version
française du site ruby-lang c’est la 1.8.6 qui est considérée comme
dernière stable…

Comment avez-vous installé Ruby?

Arthur Pétry wrote:

Bonjour � tous.>
Je d�barque un peu l�, mais dans Rails < 2.2 il y a des probl�mes de
compatibilit� avec ruby 1.8.7 visiblement.

Je n’arrive pas � trouver � partir de quelle version exactement Rails
est compatible avec ruby 1.8.7, et j’ai trouv� �tonnamment peu de
chose sur ce probl�me via google…

Y a quelques infos l� :

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484351#10

qui pointe sur ces modifications l� :

http://github.com/rails/rails/commit/7391f7728d96c2ec0113de57f3316c191043ad2c
http://github.com/rails/rails/commit/4e4bcb4c6b08ed392cd5576dcfc252ef574a1b88
http://github.com/rails/rails/commit/1d18651ea36e2ba274b6c2e0fd4edd425e028589
http://github.com/rails/rails/commit/0b21ac5118c293b43e5370d7a3da980514f089a2
http://github.com/rails/rails/commit/549c81db4a9ca941ea65ae2edafb0f34784f12f2
http://github.com/rails/rails/commit/f67b070facef6574df3c4386e3975242273fe456
http://github.com/rails/rails/commit/db11ef9546b1ad16cf539395b75450c1c8e9714c

Je ne ma�trise pas assez github pour savoir quelles versions de rails
incluent ces modifications ;-(
Bon par contre ces modifications datent du 1er juin, c’est d�j� une
bonne info !

Je me demande en fait s’il y a pas une version de rails 2.1 voire 2.0
compatible avec ruby 1.8.7 ?

A+
Arthur


#14

Je d�barque un peu l�, mais dans Rails < 2.2 il y a des probl�mes de
compatibilit� avec ruby 1.8.7 visiblement.
Pardon je viens juste de me rendre compte du “Rails < 2.2.2”, pour ça je
ne sais pas, nous sommes passé de Ruby 1.8.6 à 1.8.7 avec Rails 2.2.2.