Como hacer que Apache en Windows ejecute archivos rb y rhtml

Hola,

Tengo Ruby (1.9.1) y Rails (2.3.6) instalado sobre Windows Xp. Tengo
instalado el servidor Apache (2.2.14) y Tomcat (5.5.28).

He intentado configurar Ruby sobre Apache con fastcgi(Sobre Webrick,
ningún problema, todo se ejecuta perfectamente). El caso es que se
accede normalmente a los archivos index.html, pero no se detectan ni los
rb, ni los rhtml de Ruby.

Mi pregunta es, ¿que habría que poner en el archivo httpd.conf de Apache
para que reconozca los app_controlers.rb de Ruby?.

He intentado con el mod_ruby.so y con mod_ruby.dll, pero Apache2 siempre
dice que en la instrucción “Load ruby_module modules/mod_ruby.so”, no
puede cargar el módulo ruby_module, porque no se encuentra. El módulo
mod_ruby.so es de una versión lo más nueva que he encontrado y está en
el directorio “modules” de Apache, pero no hay modo. Siempre me dice que
el módulo no se encuentra y Apache no arranca.

No sé si el problema es del propio httpd.exe de Apache, que el Binario
2.2.14 que viene con el instalador de Windows, no se ha compilado con
soporte para Ruby y por eso falla el ruby_module.

¿Alguien sabe como se puede obtener una versión de Apache con soporte
“ruby_module”? para Windows Xp. Ya he visto que en Debian y Ubuntu, la
cosa debe estar más facil, pero en Windows, no encuentro la manera.

Gracias

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs