Commande % sudo apt-get install ruby irb rdoc


#1

N’ayant pas réussi à ce jour à utiliser convenablement irb (question
des signes spéciaux comme @) j’ai décidé de charger Ubuntu sur mon
PC.J’ai donc deux systèmes d’exploitation à disposition.
Dans l’univers Window j’utilise Ruby que j’étudie en auto-didacte.
Malheureusement j’aimerais faire un large usage d’irb mais je ne suis
jamais arrivé à utiliser les signes spéciaux.
C’est Scite que j’utilise comme éditeur de textes.
Dans la documentation officielle de Ruby il est mentionné que l’on
peut charger de manière automatique ruby avec irb au moyen d’une
commande

% sudo apt-get install ruby irb rdoc

Ou faut-il introduire cette commande et dans un deuxième temps comment
faut-il charger Scite ?
Dans Window une saisie peut être faite via l’écran “Invite de
commande”. Dans le monde Unix je crois qu’il faut accéder à un
serveur ?
Merci de m’aider.
mosar


#2

On Sunday 15 March 2009 14:27:45 mosar wrote:

% sudo apt-get install ruby irb rdoc

Ou faut-il introduire cette commande et dans un deuxième temps comment
faut-il charger Scite ?
Dans Window une saisie peut être faite via l’écran “Invite de
commande”. Dans le monde Unix je crois qu’il faut accéder à un
serveur ?
Merci de m’aider.
mosar

This is an English-only channel, friend. However, you should find a mail
in
French with some explanations in your inbox.

Cheers,

Emm


#3

Le 15 mars à 18:11, Emmanuel Surleau a écrit :

On Sunday 15 March 2009 14:27:45 mosar wrote:

Merci de m’aider.
mosar

This is an English-only channel, friend.

Note that there is a french speaking group under the usenet hierarchy,
fr.comp.lang.ruby, also accessible through google groups.

To get back to the question, the windows one-click installer for ruby
has an option for the european keybords during the install process.
Checking that option seems to work more or less (I’m seeing display
problems when I navigate using arrow keys or use backspace).

On the other hand, if you just want to try a few ruby scripts, you could
also install Cygwin and use the Ruby ineterpreter packaged within.

Fred