Cmake can't find 'gnuradio-pmt'

Hello All:
this is my first time on the list. I’m running gnuradio 3.7.6.1
with
pybombs. I’m now trying to install OpenLTE which is dependent on
Gnuradio
and when it calls cmake to check for gnuradio’s packages it can’t find
it.
Originally, the ‘FindGnuradio.cmake’ file wasn’t in the cmake/modules
directory, so that was an easy fix, now it runs a little further, and
this
is the output:

– Boost version: 1.54.0

– Found the following Boost libraries:

– system

Checking for GNU Radio Module: RUNTIME

  • INCLUDES=/home/cnlsdr1/pybombs/include

  • LIBS=/home/cnlsdr1/pybombs/lib/libgnuradio-runtime.so

GNURADIO_RUNTIME_FOUND = TRUE

Checking for GNU Radio Module: BLOCKS

  • INCLUDES=/home/cnlsdr1/pybombs/include

  • LIBS=/home/cnlsdr1/pybombs/lib/libgnuradio-blocks.so

GNURADIO_BLOCKS_FOUND = TRUE

Checking for GNU Radio Module: FILTER

  • INCLUDES=/home/cnlsdr1/pybombs/include

  • LIBS=/home/cnlsdr1/pybombs/lib/libgnuradio-filter.so

GNURADIO_FILTER_FOUND = TRUE

Checking for GNU Radio Module: PMT

– checking for module ‘gnuradio-pmt’

– package ‘gnuradio-pmt’ not found

  • INCLUDES=GNURADIO_PMT_INCLUDE_DIRS-NOTFOUND

  • LIBS=GNURADIO_PMT_LIBRARIES-NOTFOUND

– Could NOT find GNURADIO_PMT (missing: GNURADIO_PMT_LIBRARIES
GNURADIO_PMT_INCLUDE_DIRS)

GNURADIO_PMT_FOUND = FALSE

CMake Error at /usr/share/cmake-2.8/Modules/FindGnuradio.cmake:97
(message):

Required GNU Radio Component: PMT missing!

Call Stack (most recent call first):

/usr/share/cmake-2.8/Modules/FindGnuradio.cmake:123 (GR_MODULE)

CMakeLists.txt:92 (find_package)

– Configuring incomplete, errors occurred!

I usually just figure this stuff out on my own or with the help of
coworkers, but i figured i’d give the group a try.

Any help with this would be greatly appreciated.

Thanks,

-ben

On Tue, Feb 24, 2015 at 7:23 PM, ben Gee [email protected] wrote:

GNURADIO_RUNTIME_FOUND = TRUE

– package ‘gnuradio-pmt’ not found
CMake Error at /usr/share/cmake-2.8/Modules/FindGnuradio.cmake:97

-ben

It looks like there’s some confusion in the configuration process. It
looks
like it’s using FindGnuradio.cmake, which will be removed in the next
API
version update since we are now using the GnuradioConfig.cmake method of
doing this. This shouldn’t be a problem, but It looks like there might
be a
bug that’s causing this because of the install and cmake paths.

Take a look at /usr/share/cmake-2.8/Modules/FindGnuradio.cmake and go to
the very last line and make this substitution:

-GR_MODULE(PMT gnuradio-pmt pmt/pmt.h gnuradio-pmt)
+GR_MODULE(PMT gnuradio-runtime pmt/pmt.h gnuradio-pmt)

The PMT library is provided by gnuradio-runtime, so they are in the same
package config info.

Tom

thanks Tom! That seemed to get me one step further.
a couple of notes:

  1. do you any thoughts on the next error (output included below)? looks
    like the same thing except, polarssl is now not mentioned in the
    findgnuradio.cmake file.
  2. a friend mentioned to me that there is a pybombs recipe for openlte
    which i ran successfully (while feeling like a bit of a dope for not
    thinking of it first).

with that said, shouldn’t i still be able to compile the source for
openlte
without using its pybombs recipe? I would like to resolve the cmake
error,
but in the interest of not wasting your time, please understand that
openlte DID compile through pybombs. I guess the cmake issue is just a
bit
bothersome, especially if i want to compile GNURadio code that is out of
tree for pybombs.

thanks,
-ben

output after making the previously suggested

[email protected]:~/openlte_v00-18-03/build/CMakeFiles$ cmake …/
– Build type not specified: defaulting to release.
– Boost version: 1.54.0
– Found the following Boost libraries:
– system
Checking for GNU Radio Module: RUNTIME

  • INCLUDES=/home/cnlsdr1/pybombs/include
  • LIBS=/home/cnlsdr1/pybombs/lib/libgnuradio-runtime.so
    GNURADIO_RUNTIME_FOUND = TRUE
    Checking for GNU Radio Module: BLOCKS
  • INCLUDES=/home/cnlsdr1/pybombs/include
  • LIBS=/home/cnlsdr1/pybombs/lib/libgnuradio-blocks.so
    GNURADIO_BLOCKS_FOUND = TRUE
    Checking for GNU Radio Module: FILTER
  • INCLUDES=/home/cnlsdr1/pybombs/include
  • LIBS=/home/cnlsdr1/pybombs/lib/libgnuradio-filter.so
    GNURADIO_FILTER_FOUND = TRUE
    Checking for GNU Radio Module: PMT
  • INCLUDES=/home/cnlsdr1/pybombs/include
  • LIBS=/home/cnlsdr1/pybombs/lib/libgnuradio-pmt.so
    GNURADIO_PMT_FOUND = TRUE
    – Could NOT find GNURADIO_OSMOSDR (missing:
    GNURADIO_OSMOSDR_INCLUDE_DIRS)
    – UHD LIBRARIES /home/cnlsdr1/pybombs/lib/libuhd.so
    – UHD INCLUDE DIRS /home/cnlsdr1/pybombs/include
    – checking for module ‘polarssl’
    – package ‘polarssl’ not found
    – POLARSSL LIBRARIES /usr/lib/libpolarssl.so
    – POLARSSL INCLUDE DIRS /usr/include
    CMake Error at CMakeLists.txt:103 (message):
    GNURadio Osmosdr required to compile openLTE
    (http://sdr.osmocom.org/trac/wiki/GrOsmoSDR)

– Configuring incomplete, errors occurred!

On Thu, Feb 26, 2015 at 4:36 PM, ben Gee [email protected] wrote:

thanks Tom! That seemed to get me one step further.
a couple of notes:

  1. do you any thoughts on the next error (output included below)? looks
    like the same thing except, polarssl is now not mentioned in the
    findgnuradio.cmake file.

First, that’s now a problem with the openlte build system and nothing to
do
with GNU Radio.

Second, it’s not polarssl that’s the problem here. When it says it
didn’t
find it, it means that pkg-config couldn’t locate it, but you’ll notice
the
second two lines have found the libraries and headers because cmake went
and looked for them on its own.

The real problem is the next line where it says it can’t find
gr-osmosdr,
which is either not installed or is installed somewhere where the
openlte
cmake system isn’t able to find it.

  1. a friend mentioned to me that there is a pybombs recipe for openlte

which i ran successfully (while feeling like a bit of a dope for not
thinking of it first).

Might as well stick with pybombs. It knows what it’s doing with these
things.

Specifically, since it all gets installed into the same prefix, that’s
helping cmake find things easier.

Tom

with that said, shouldn’t i still be able to compile the source for
openlte

ok, Thanks. i’ll work with it some more. I’m now having issues running
anything that’s installed using pybombs as root (a requirement of
openlte).
That’s an OS thing though, not gnuradio related.

thanks for the answers Tom, i appreciate the time.

-b

Just to be fair to the openLTE folks, it builds just fine here with a
properly installed GNU Radio.

Ron

I have had a working version of OpenLTE on a different system with a
traditional build of GNURadio. When i got new computers at my lab i
decided
to build gnuradio using pyboms because it seemed like the newer more
streamlined option.

Are you using pybombs to install Gnuradio, Ron?

I haven’t tried pybombs. I always build from source. It doesn’t seem
like that much of a hassle to me, but I’m a long time software
developer.

Ron

Just for the sake of the archives and marking this issue closed, i was
finally able to get gnuradio and the openlte pybombs recipe to run, i
had
to:

  1. give openlte sudo privileges
  2. add libuhd.so.003 to a .conf file i made called
    /etc/ld.so.conf.d/randomLibs.conf
  3. run sudo ldconfig.
    I’m still suspecting the manual adding of libuhd has to do with the
    isolated environment of pybombs. I’m definitely not giving up on it yet
    though.

hope this isn’t too off topic, just hoping to help some other new users
if
they’re branching out, plus i think the libuhd issue is one that could
occur in other situations.

thanks,
-b

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs