Cmake build of Gnu Radio failing this morning

Fedora 12, 32-bit:

[ 0%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/msg/msg_accepter.cc.o
[ 0%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/msg/msg_accepter_msgq.cc.o
[ 0%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/msg/msg_queue.cc.o
[ 0%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/pmt/pmt_unv.cc.o
[ 0%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/pmt/pmt.cc.o
[ 1%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/pmt/pmt_io.cc.o
[ 1%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/pmt/pmt_pool.cc.o
[ 1%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/pmt/pmt_serialize.cc.o
[ 1%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/realtime.cc.o
[ 1%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/sys_pri.cc.o
[ 1%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/thread_body_wrapper.cc.o
[ 2%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/thread_group.cc.o
Linking CXX shared library libgruel.so
make[2]: *** [gruel/src/lib/libgruel.so.0.0.0] Error 1
make[1]: *** [gruel/src/lib/CMakeFiles/gruel.dir/all] Error 2

This is from a clean source tree, with -DENABLE_VOLK=NO on the cmake


Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

On 11/08/2011 04:24 AM, Marcus D. Leech wrote:

[ 0%] Building CXX object gruel/src/lib/CMakeFiles/gruel.dir/pmt/pmt.cc.o
[ 2%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/thread_group.cc.o
Linking CXX shared library libgruel.so
make[2]: *** [gruel/src/lib/libgruel.so.0.0.0] Error 1
make[1]: *** [gruel/src/lib/CMakeFiles/gruel.dir/all] Error 2

This is from a clean source tree, with -DENABLE_VOLK=NO on the cmake

I dont see an error. Why do you think its volk?

-Josh

gruel/src/lib/CMakeFiles/gruel.dir/pmt/pmt_unv.cc.o
gruel/src/lib/CMakeFiles/gruel.dir/thread_body_wrapper.cc.o
[ 2%] Building CXX object
gruel/src/lib/CMakeFiles/gruel.dir/thread_group.cc.o
Linking CXX shared library libgruel.so
make[2]: *** [gruel/src/lib/libgruel.so.0.0.0] Error 1
make[1]: *** [gruel/src/lib/CMakeFiles/gruel.dir/all] Error 2

This is from a clean source tree, with -DENABLE_VOLK=NO on the cmake

And another piece of data–an autotools build worked just fine (with
-disable-volk)


Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs