Closing a GdkPixbufLoader ignoring errors

Quoting
http://library.gnome.org/devel/gdk-pixbuf/unstable/GdkPixbufLoader.html#gdk-pixbuf-loader-close
:

“If you’re just cancelling a load rather than expecting it to be
finished, passing NULL for error to ignore it is reasonable.”

Current implementation doesn’t allow for it:

-=----=----=----=----=----=----=—
static VALUE
loader_close(self)
VALUE self;
{
GError *error = NULL;
gboolean res;

res = gdk_pixbuf_loader_close(_SELF(self), &error);
if(error)
    RAISE_GERROR(error);

return CBOOL2RVAL(res);

}
-=----=----=----=----=----=----=—

What is the correct rg2 idiom for doing that? Using #close(nil) sounds
pretty stupid, but then, what to do? Maybe #close_noerror but then the
principle of least surprise (guessing method names and ways to call
them) is pretty broken :confused:


Guillaume C. - http://zarb.org/~gc/

end
makes sense!

I wanted to update the hiki documentation accordingly, but the
“generic” username/password I was previously using doesn’t seem to
work anymore (login “ruby-gnome2…”).


Guillaume C. - http://zarb.org/~gc/

Hi,

In [email protected]
“[ruby-gnome2-devel-en] closing a GdkPixbufLoader ignoring errors” on
Mon, 31 Mar 2008 00:13:16 +0200,
“Guillaume C.” [email protected] wrote:

loader_close(self)
}
-=----=----=----=----=----=----=—

What is the correct rg2 idiom for doing that? Using #close(nil) sounds
pretty stupid, but then, what to do? Maybe #close_noerror but then the
principle of least surprise (guessing method names and ways to call
them) is pretty broken :confused:

Is it good enough to use rescue?

begin
pixbuf_loader.close
rescue Gdk::PixbufError
end

It is clear for me.

Thanks,

kou

I wanted to update the hiki documentation accordingly, but the
“generic” username/password I was previously using doesn’t seem to
work anymore (login “ruby-gnome2…”).

I removed authentication on POST and introduced bayes
filter. But bayes DB isn’t good enough. So your post is
rejected.

I registered your post as ham. Could you post again?

I’m sorry but I don’t understand “registered your post as ham”…

I’ve tried to login again but it failed (though I wonder if the old
username was not with HTTP authentication), and I’ve tried to modify
the page again, but still the same results: after clicking on “save” I
have again the edit box, but this time no “preview” and “save” button,
and if I try to go back to the page I see that the modifications are
not saved.


Guillaume C. - http://zarb.org/~gc/

Kouhei disabled authentication and has installed spam filtering
instead. Your message was mistakenly detected as spam so he marked it
as non-spam (ham).

I would suggest to use password protection and put the password
directly on the website. It’s very unlikely that a bot find the
password and use it for posting content.

Mathieu

2008/4/1, Guillaume C. [email protected]:

Hi,

In [email protected]
“Re: [ruby-gnome2-devel-en] closing a GdkPixbufLoader ignoring errors”
on Mon, 31 Mar 2008 17:29:16 +0200,
“Guillaume C.” [email protected] wrote:

I wanted to update the hiki documentation accordingly, but the
“generic” username/password I was previously using doesn’t seem to
work anymore (login “ruby-gnome2…”).

I removed authentication on POST and introduced bayes
filter. But bayes DB isn’t good enough. So your post is
rejected.

I registered your post as ham. Could you post again?

Thanks,

kou

On Mon, Mar 31, 2008 at 6:05 PM, Mathieu B.
[email protected] wrote:

Kouhei disabled authentication and has installed spam filtering
instead. Your message was mistakenly detected as spam so he marked it
as non-spam (ham).

Ah. And how long does it take to show up on the website? It’s still not
there…

“generic” username/password I was previously using doesn’t seem to

[email protected]
[email protected]
https://lists.sourceforge.net/lists/listinfo/ruby-gnome2-devel-en


Guillaume C. - http://zarb.org/~gc/

Ah. And how long does it take to show up on the website? It’s still not there…

Sorry… Your post still marked as spam…
I’ve added an account that is same username/password before. If you login
from menu, your post will not be filtered.

Thanks, it’s fine!


Guillaume C. - http://zarb.org/~gc/

Hi,

Mathieu, thanks for follow my English.

2008/4/1, Guillaume C. [email protected]:

On Mon, Mar 31, 2008 at 6:05 PM, Mathieu B. [email protected] wrote:

Kouhei disabled authentication and has installed spam filtering
instead. Your message was mistakenly detected as spam so he marked it
as non-spam (ham).

Ah. And how long does it take to show up on the website? It’s still not there…

Sorry… Your post still marked as spam…
I’ve added an account that is same username/password before. If you
login
from menu, your post will not be filtered.

Thanks,

kou

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs