Closed stream error running unit tests through rake

Hi,

I have been trying to run unit tests through rake and getting
closed stream error. The trace output is mentioned below:

http://pastie.org/828398

I am on a Mac OSX 10.5.6 (leopard). And having the following
setting

% Ruby - ruby 1.8.6 (2008-08-11 patchlevel 287) [universal-darwin9.0]
% Rails - 2.3.5
% mysql gem - (2.8.1, 2.7)
% MySql Server - 5.1.44 (installed from binary)

I have followed all the database setup steps before trying to run
the unit tests like:

% rake db:create:all
% rake db:migrate
% rake db:test:prepare

I also tried to create an new rails project and tried to execute

% rake test:units

but getting the same error as mentioned in the pastie
above. Went through couple of posts in different forums also but they
didn’t help much!

I also tried “rake db:schema:dump” as one of the suggested. But the
error is till the same.

Any suggestion or hint on this will be great.

Thanks,
Subh

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs