The word Inject essentially means to introduce something into a
system and yet the inject method iterates over a series elements
carrying forward some sort of result at each next step.
Hence would it not make more sense to name it " accumulate" which
seems to me more explicit and intuitive?
Yes I realize that an alias may be used for this, however, I am
looking for insight as to the reason “inject” was chosen over
something better suited like accumulate.
(Eg. I am not looking for “just use alias” or “it’s tradition” or
“that’s just how it is” as answers.)
Thank you very much for any insight and/or good discussion on this.