Changing worker user account causes throttling of response size?

Hi all,

I’m setting up Nginx on a RHEL machine. I am proxying to an
ASP.NETapplication. The
ASP.NET application has some nifty built-in document viewer tool, and so
it
often downloads relatively large files (in the realm of 1MB-5MB, or
larger). Nginx, when using the default ‘nginx’ worker user account, has
been working fine. I recently tried enabling auth_basic, and because of
that tried changing the worker user account to my own personal user
account, so that it can access the htpasswd file from my home directory.
This was working fine as well, until we started getting phone calls
about
the document viewer from the ASP.NET application saying it did not
receive
the entire document download. I investigated, and it looks like Nginx is
throttling that ASP.NET response -> Nginx proxy -> Web user, after I
changed the worker process user account. To test this, I removed the
auth_basic lines that I added, and left the user account as my personal
account, still. It continued to throttle the response size. It seems to
cut
the response off at around 48k pretty consistently - I cannot tell if
it’s
a time-out or a throttle, but it’s generally around 48k of a response
before being cut off. To further test, I switched back to the ‘nginx’
worker user account, but added back in the auth_basic lines and the
responses return to normal with no throttling.

So to my untrained eye, it looks like switching this user account is
causing it to pick up some different configuration settings, or
something,
and chooses to throttle response sizes. I scanned through all of the
available config files and did not see anything that stood out to me. I
scanned the documentation also, but none of the timeout or throttling
options looked relative to this.

Does anyone have any ideas?

Thanks in advance,

Ryan

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs