Changing the IP of USRP2

Hi All,

I am a newbee to grc and USRP. I need some help regarding changing the
address of the USRP. I checked the previous threads on this discussion
searched a bit to do this, but couldn’t get it working.

My host PC IP is

My USRP1’s IP is

My USRP2’s IP is Currently. I want to set this IP to

I disconnected USRP1 and tried this command
sudo ./ --ifc=eth0 --new-ip=

The output is

(‘Opening raw socket on interface:’, ‘eth0’)
(‘Loading packet with ip address:’, ‘’)
Sending packet (22 bytes)

I removed the power source and connected it back and tried to ping the
IP, I dont get any reply. Also I tried uhd_find_devices but
shows the same old IP

I tried the second approach
./usrp_burn_mb_eeprom --args= --key=ip-addr

I get this as the output:
./usrp_burn_mb_eeprom: symbol lookup error: ./usrp_burn_mb_eeprom:
undefined symbol: _ZN3uhd6device4makeERKNS_13device_addr_tEm

Can some1 help me understand whats happening here ? I appreciate the


Hello Vaibhav,

you’re getting runtime linker errors.
My diagnosis here is that on your PC there’s a mix of different versions
of USRP drivers installed, which will not work. Please make sure to
uninstall all installations of UHD, install the latest version for your
linux, and re-build GNU Radio to make it use that version.

It’s a bit surprising to see usrp2_recovery not work; did you directly
connect the USRP to your PC using a Gigabit Ethernet-compatible cable
and network controller?