Changes to mongrel_cluster.yml isn't taking

So, I’ve been able to deploy a single app just fine. But in my
attempts to run multiple rails apps within the same domain, I made a
change by adding
prefix: /app1
to my mongrel_cluster.yml file.

Using Capistrano, I ran cap:restart to restart my mongrel processes,
but I saw no reference to prefix in the mongrel start command in
mongrel.log:
** USR2 signal received.
** Restarting with arguments: ruby /usr/lib/ruby/gems/1.8/gems/
mongrel-1.1.1/bin/mongrel_rails start -d -a 0.0.0.0 -p 8000 -P /srv/
www/htdocs/app1/releases/20080111175042/tmp/pids/dispatch.8000.pid -e
production -c /srv/www/htdocs/app1/releases/20080111175042 -l /srv/www/
htdocs/app1/releases/20080111175042/log/mongrel.log

It seems any change to my mongrel_cluster.yml is not being picked up.
To further test this, I altered the yml file to send its log file to
mongrel_test.log instead of mongrel.log. And still, it’s using
mongrel.log.

What could I be doing wrong?

Thanks,

-A.

On Jan 11, 2008, at 12:36 PM, me wrote:

It seems any change to my mongrel_cluster.yml is not being picked up.
To further test this, I altered the yml file to send its log file to
mongrel_test.log instead of mongrel.log. And still, it’s using

  1. What version of mongrel_cluster are you running?
  2. You’ve checked in your mongrel_cluster.yml file, and
  3. It’s on your app servers?

Cheers,
-j

  1. What version of mongrel_cluster are you running?

1.1.1

  1. You’ve checked in your mongrel_cluster.yml file, and

yes.

  1. It’s on your app servers?

yes. Local and remote (where it’s deployed).

On Jan 11, 2008, at 2:19 PM, me wrote:

  1. It’s on your app servers?

yes. Local and remote (where it’s deployed).

What’s the value of :mongrel_conf in your config/deploy.rb and config/
deploy/production.rb files?

-j

I don’t have anything associated with :mongrel_conf.
Is there a default value?

Just for the record, looks like what happened is that in spite of my
assigning :mongrel_conf, nothing I did to my mongrel_cluster.yml would
change its settings.

Reason was because of what I had in my script/spin file:

/path/current/script/process/spawner -p 8000 -i 2

From what I understand, it should have instead used something like
this:

/usr/bin/mongrel_rails cluster::start -C /path/current/config/
mongrel_cluster.yml

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs