Changes to ActiveMailer?


#1

I recently updated Rails on my development server. All went well.
But I just noticed that my contact page now generates the following
error when a contact is submitted.

Net::SMTPAuthenticationError (530 5.7.0 Must issue a STARTTLS command
first. 6sm1162914qwd.18)

If I revert back to Rails 2.2.2 - no problem.

Does anyone have any idea what changed to ActiveMailer may be
producing this error?

Thanks


#2

I found this in the changelog for ActiveMailer:

"Turn on STARTTLS if it is available in Net::SMTP (added in Ruby
1.8.7) and the SMTP server supports it (This is required for Gmail‘s
SMTP server) 1336 [Grant Hollingworth] "

Oddly enough I’m using gmail and it works with Rails 2.2.2! This
change was made to enable gmail and in my case it seems to have broken
gmail. I can’t find any documentation on how STARTTLS must be
accounted for in the config.

Any help will be greatly appreciated.


#3

Need to install smtp-tls as a result of the change.


#4

Looks like your auth method!

Blog: http://random8.zenunit.com/
Learn rails: http://sensei.zenunit.com/