Capistrano: update_code - "No such file or directory" -


#1

Hi folks,

I’ve been staring at this one for far too long. I’m using Windows SVN
client + Capistrano to deploy rails app to my hosted server. I can’t
seem to get a single successful deployment. I keep getting this "No
such file or directory - svn log -q -rhead
http://myhost.com/svn/spclient/trunk " . I run this svn command from
the cmd prompt and it returns error free. Has anyone else seen this out
there?

Thanks for help,

Tom O

see below -->>>>

C:…Rails>rake deploy --trace
(in C:…Rails)
** Invoke deploy (first_time)
** Invoke remote:deploy (first_time)
** Execute remote:deploy
loading configuration
c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.1.0/lib/ca
pistrano/recipes/standard.rb
loading configuration ./config/deploy.rb

  • executing task deploy
    ** transaction: start
  • executing task update_code
  • querying latest revision…
    c:/ruby/bin/rake.bat: No such file or directory - svn log -q -rhead
    http://myhost.com/svn/spclient/trunk
    *** [update_code] transaction: rollback
  • [update_code] rolling back
  • executing “rm -rf
    /home/tomeeo/sites/spclient/releases/20060601080302”
    servers: [“spc.myhost.com”]

#2

Tom,

Have you got it working? or a workaround? I am having the same problem
on windows as well. My host is dreamhost, and I have tried all the
various ways to access svn, but all return the same message as you got.

Any ideas?

Steven

Tom On wrote:

Hi folks,

I’ve been staring at this one for far too long. I’m using Windows SVN
client + Capistrano to deploy rails app to my hosted server. I can’t
seem to get a single successful deployment. I keep getting this "No
such file or directory - svn log -q -rhead
http://myhost.com/svn/spclient/trunk " . I run this svn command from
the cmd prompt and it returns error free. Has anyone else seen this out
there?

Thanks for help,

Tom O

see below -->>>>

C:…Rails>rake deploy --trace
(in C:…Rails)
** Invoke deploy (first_time)
** Invoke remote:deploy (first_time)
** Execute remote:deploy
loading configuration
c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.1.0/lib/ca
pistrano/recipes/standard.rb
loading configuration ./config/deploy.rb

  • executing task deploy
    ** transaction: start
  • executing task update_code
  • querying latest revision…
    c:/ruby/bin/rake.bat: No such file or directory - svn log -q -rhead
    http://myhost.com/svn/spclient/trunk
    *** [update_code] transaction: rollback
  • [update_code] rolling back
  • executing “rm -rf
    /home/tomeeo/sites/spclient/releases/20060601080302”
    servers: [“spc.myhost.com”]

#3

After quite a bit more thinking, I figured out I needed to install the
command line version of svn as it appeared to be querying with that
command from the local computer.

Check if you have it installed by typing “svn help” on the command line.

Steven

Tom On wrote:

Hi folks,

I’ve been staring at this one for far too long. I’m using Windows SVN
client + Capistrano to deploy rails app to my hosted server. I can’t
seem to get a single successful deployment. I keep getting this "No
such file or directory - svn log -q -rhead
http://myhost.com/svn/spclient/trunk " . I run this svn command from
the cmd prompt and it returns error free. Has anyone else seen this out
there?

Thanks for help,

Tom O

see below -->>>>

C:…Rails>rake deploy --trace
(in C:…Rails)
** Invoke deploy (first_time)
** Invoke remote:deploy (first_time)
** Execute remote:deploy
loading configuration
c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.1.0/lib/ca
pistrano/recipes/standard.rb
loading configuration ./config/deploy.rb

  • executing task deploy
    ** transaction: start
  • executing task update_code
  • querying latest revision…
    c:/ruby/bin/rake.bat: No such file or directory - svn log -q -rhead
    http://myhost.com/svn/spclient/trunk
    *** [update_code] transaction: rollback
  • [update_code] rolling back
  • executing “rm -rf
    /home/tomeeo/sites/spclient/releases/20060601080302”
    servers: [“spc.myhost.com”]