Capistrano still asks for the 1st password even though I've set up an ssh key?

Hi,

Background: I’ve setup an ssh key to avoid having to use passwords
with capistrano per
http://www.picky-ricky.com/2009/01/ssh-keys-with-capistrano.html.
A basic ssh to my server does work fine without asking for passwords.
I’m using “dreamhost.com” for hosting.

Issue - When I run ‘cap deploy’ I still get asked for the 1st password
(even through the previous 2nd and 3rd password requests are now
automated). It is the capistrano command that start with “git clone -
q ssh:…” for which the password is being requested.

Question - Is there something I’ve missed? How can I get “cap deploy”
totally passwordless?

Some excerts from config/deploy.rb are:

set :use_sudo, false
ssh_options[:keys] = [File.join(ENV[“HOME”], “.ssh”, “id_rsa”)]
default_run_options[:pty] = true

thanks

Greg,

Where is your repository? I wonder if your key is getting you into
your shell and then it is prompting for your password to access the
repo?

–Tom

it’s on the same server - actually got it figured out with help of
some others - the following got it working:

set :repository, “/home/me/git_repo/myapp.git”
set :local_repository, “ssh://[email protected]/home/me/git_repo/
myapp.git”

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs