Capistrano - SSH Port


#1

I’ve been deploying with Capistrano for a while now, and have had no
problems… until now.

When I try and do a “cap deploy”, cap tries to connect to my remote
server
via SSH on port 22… even though in my deploy.rb, I’ve had the
following
set:
ssh options[:port] = 8081

I did a “sudo gem update --remote capistrano”, and I’m up to speed on
the
latest release, so am utterly confused as to why it’s not picking up
this
option from the config.

Any ideas ?


#2

On Apr 21, 2006, at 9:44 PM, Dylan S. wrote:

I’ve been deploying with Capistrano for a while now, and have had
no problems… until now.

When I try and do a “cap deploy”, cap tries to connect to my remote
server via SSH on port 22… even though in my deploy.rb, I’ve had
the following set:
ssh options[:port] = 8081

Is that a space or underscore between “ssh” and “options”? It should be:

ssh_options[:port] = 8081

I just tried it locally and it seems to be honoring the port here.

  • Jamis