Capistrano problem with mongrel_cluster.yml

Hello there

I am having a little trouble with capistrano. I have a rails app, which
is running on my hosting server. it was set up originally using this
tutorial:

http://www.hostingrails.com/Capistrano-2-x-Deploying-Your-Rails-Application-on-HostingRails-com

Its all been uploaded using capistrano all fine.

my problem is trying to update locally then upload to the server.

I have made some changes to the site and I am trying to run cap deploy
(which i think is the right command).

The cap file config is set up to copy from local:

set :repository, "."
set :scm, :none
set :deploy_via, :copy

set :scm, :none

when i run cap deploy, it does all the upload to the server as expected,
but always ends with an error -

  • executing `deploy:restart’
  • executing “ln -s
    /Library/Rails//shared/config/mongrel_cluster.yml
    /Library/Rails/
    /current/config/mongrel_cluster.yml”
    servers: ["..."]
    [...] executing command
    *** [err :: ...] ln:
    *** [err :: ...] creating symbolic link
    `/Library/Rails//current/config/mongrel_cluster.yml’
    *** [err :: ...] : File exists
    *** [err :: ...]
    command finished
    failed: "sh -c 'ln -s
    /Library/Rails/
    /shared/config/mongrel_cluster.yml
    /Library/Rails/****/current/config/mongrel_cluster.yml’" on ...

I have tried all kinds of shennanigans on the server to get it to work,
but to no avail (i.e. moving the file etc)
Anyone have any ideas as to what i can do to fix this?
I can add more code if needed to show you my config files etc
any tips are most welcome

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs