Capistrano on CentOS won't go

[[email protected] ~]$ cap -T
/usr/lib/ruby/site_ruby/1.8/rubygems.rb:523:in report_activate_error': Could not find RubyGem net-scp (>= 1.0.0) (Gem::LoadError) from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:131:inactivate’
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:155:in activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:154:ineach’
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:154:in activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:49:ingem’
from /usr/bin/cap:18
[[email protected] ~]$

I did the same gem install on my Ubuntu, and it works fine there.
Anyone have a suggestion? I know, I know, RedHat is typically just
broken.

Xeno C. wrote:

I did the same gem install on my Ubuntu, and it works fine there. Anyone
have a suggestion? I know, I know, RedHat is typically just broken.

so I installed net-scp and net-ssh-gateway, and it goes. I thought gem
was supposed to install dependencies…?
xc

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs