Capistrano installation error--Zlib buffer error

I’m trying to install Capistrano. When I run gem install Capistrano
–include-dependencies, I get the following error:

ERROR: While executing gem … (Zlib::BufError)
buffer error

Anyone got any ideas what’s causing this and how I can fix it? I’d
really like to use Capistrano to deploy my rails app, but I need to
install it first…

Thanks,
Myron

Actually, I did some more google searching and found the solution at:

http://dontrepeatyourself.wordpress.com/2007/05/14/zlibbuferror/

Basically, I just had to update my RubyGems using gem update --system.

  • Myron

Myron M. wrote:

I’m trying to install Capistrano. When I run gem install Capistrano
–include-dependencies, I get the following error:

ERROR: While executing gem … (Zlib::BufError)
buffer error

Anyone got any ideas what’s causing this and how I can fix it? I’d
really like to use Capistrano to deploy my rails app, but I need to
install it first…

Thanks,
Myron

gem update --include-dependencies

gem update --system

BTW, for more targeted help, check out the Capistrano group:

http://groups.google.com/group/capistrano

n

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs