Capistrano deploy:assets:backup_manifest

Hi

Deploying an ruby on rails project with capistrano, getting the
following error

INFO [1cc980d1] Finished in 966.458 seconds with exit status 0
(successful).
** Invoke deploy:assets:backup_manifest (first_time)
** Execute deploy:assets:backup_manifest
DEBUG [2935fe97] Running /usr/bin/env if test ! -d
/home/deployer/folder/releases/20150724150527; then echo “Directory does
not exist ‘/home/deployer/folder/releases/20150724150527’” 1>&2; false;
fi as [email protected]
DEBUG [2935fe97] Command: if test ! -d
/home/deployer/folder/releases/20150724150527; then echo “Directory does
not exist ‘/home/deployer/folder/releases/20150724150527’” 1>&2; false;
fi
DEBUG [2935fe97] Finished in 3.683 seconds with exit status 0
(successful).
INFO [3bcfeae2] Running /usr/bin/env mkdir -p
/home/deployer/folder/releases/20150724150527/assets_manifest_backup as
[email protected]
DEBUG [3bcfeae2] Command: cd
/home/deployer/folder/releases/20150724150527 && /usr/bin/env mkdir -p
/home/deployer/folder/releases/20150724150527/assets_manifest_backup
DEBUG [3bcfeae2] ruby-1.9.3-p484 is not installed.
DEBUG [3bcfeae2] To install do: ‘rvm install ruby-1.9.3-p484’
INFO [3bcfeae2] Finished in 0.725 seconds with exit status 0
(successful).
DEBUG [43ea5568] Running /usr/bin/env ls
/home/deployer/folder/releases/20150724150527/public/assets/.sprockets-manifest*
as [email protected]
DEBUG [43ea5568] Command: cd
/home/deployer/folder/releases/20150724150527 && /usr/bin/env ls
/home/deployer/folder/releases/20150724150527/public/assets/.sprockets-manifest*
DEBUG [43ea5568] ruby-1.9.3-p484 is not installed.
DEBUG [43ea5568] To install do: ‘rvm install ruby-1.9.3-p484’
DEBUG [43ea5568] ls: cannot access
/home/deployer/folder/releases/20150724150527/public/assets/.sprockets-manifest*:
No such file or directory
DEBUG [43ea5568] Finished in 0.446 seconds with exit status 2 (failed).
DEBUG [bb101519] Running /usr/bin/env ls
/home/deployer/folder/releases/20150724150527/public/assets/manifest*.*
as [email protected]
DEBUG [bb101519] Command: cd
/home/deployer/folder/releases/20150724150527 && /usr/bin/env ls
/home/deployer/folder/releases/20150724150527/public/assets/manifest*.*
DEBUG [bb101519] ruby-1.9.3-p484 is not installed.
DEBUG [bb101519] To install do: ‘rvm install ruby-1.9.3-p484’
DEBUG [bb101519]
/home/deployer/folder/releases/20150724150527/public/assets/manifest.yml
DEBUG [bb101519] Finished in 0.368 seconds with exit status 0
(successful).
DEBUG [f04cc7f1] Running /usr/bin/env ls
/home/deployer/folder/releases/20150724150527/public/assets/manifest*.*
as [email protected]
DEBUG [f04cc7f1] Command: cd
/home/deployer/folder/releases/20150724150527 && /usr/bin/env ls
/home/deployer/folder/releases/20150724150527/public/assets/manifest*.*
DEBUG [f04cc7f1] ruby-1.9.3-p484 is not installed.
DEBUG [f04cc7f1] To install do: ‘rvm install ruby-1.9.3-p484’
DEBUG [f04cc7f1]
/home/deployer/folder/releases/20150724150527/public/assets/manifest.yml
DEBUG [f04cc7f1] Finished in 0.544 seconds with exit status 0
(successful).
INFO [2ce5f30a] Running /usr/bin/env cp ruby-1.9.3-p484 is not
installed.
To install do: ‘rvm install ruby-1.9.3-p484’
/home/deployer/folder/releases/20150724150527/public/assets/manifest.yml
/home/deployer/folder/releases/20150724150527/assets_manifest_backup as
[email protected]
DEBUG [2ce5f30a] Command: cd
/home/deployer/folder/releases/20150724150527 && /usr/bin/env cp
ruby-1.9.3-p484 is not installed.
To install do: ‘rvm install ruby-1.9.3-p484’
/home/deployer/folder/releases/20150724150527/public/assets/manifest.yml
/home/deployer/folder/releases/20150724150527/assets_manifest_backup
DEBUG [2ce5f30a] ruby-1.9.3-p484 is not installed.
DEBUG [2ce5f30a] To install do: ‘rvm install ruby-1.9.3-p484’
DEBUG [2ce5f30a] cp: target installed.\r' is not a directory DEBUG [2ce5f30a] bash: line 1: To: command not found DEBUG [2ce5f30a] bash: line 2: /home/deployer/folder/releases/20150724150527/public/assets/manifest.yml: Permission denied cap aborted! SSHKit::Runner::ExecuteError: Exception while executing as [email protected]: cp exit status: 126 cp stdout: ruby-1.9.3-p484 is not installed. To install do: 'rvm install ruby-1.9.3-p484' cp: targetinstalled.\r’ is not a directory
bash: line 1: To: command not found
bash: line 2:
/home/deployer/folder/releases/20150724150527/public/assets/manifest.yml:
Permission denied
cp stderr: Nothing written
/usr/local/rvm/gems/ruby-1.9.3-p551/gems/sshkit-1.7.1/lib/sshkit/runners/parallel.rb:16:in
rescue in block (2 levels) in execute' /usr/local/rvm/gems/ruby-1.9.3-p551/gems/sshkit-1.7.1/lib/sshkit/runners/parallel.rb:12:inblock (2 levels) in execute’
SSHKit::Command::Failed: cp exit status: 126
cp stdout: ruby-1.9.3-p484 is not installed.
To install do: ‘rvm install ruby-1.9.3-p484’
cp: target installed.\r' is not a directory bash: line 1: To: command not found bash: line 2: /home/deployer/folder/releases/20150724150527/public/assets/manifest.yml: Permission denied cp stderr: Nothing written /usr/local/rvm/gems/ruby-1.9.3-p551/gems/sshkit-1.7.1/lib/sshkit/command.rb:95:inexit_status=’
/usr/local/rvm/gems/ruby-1.9.3-p551/gems/sshkit-1.7.1/lib/sshkit/backends/netssh.rb:179:in
block in _execute' /usr/local/rvm/gems/ruby-1.9.3-p551/gems/sshkit-1.7.1/lib/sshkit/backends/netssh.rb:133:intap’
/usr/local/rvm/gems/ruby-1.9.3-p551/gems/sshkit-1.7.1/lib/sshkit/backends/netssh.rb:133:in
_execute' /usr/local/rvm/gems/ruby-1.9.3-p551/gems/sshkit-1.7.1/lib/sshkit/backends/netssh.rb:66:inexecute’
/usr/local/rvm/gems/ruby-1.9.3-p551/gems/capistrano-rails-1.1.3/lib/capistrano/tasks/assets.rake:71:in
block (5 levels) in <top (required)>' /usr/local/rvm/gems/ruby-1.9.3-p551/gems/sshkit-1.7.1/lib/sshkit/backends/abstract.rb:77:inwithin’
/usr/local/rvm/gems/ruby-1.9.3-p551/gems/capistrano-rails-1.1.3/lib/capistrano/tasks/assets.rake:67:in
block (4 levels) in <top (required)>' /usr/local/rvm/gems/ruby-1.9.3-p551/gems/sshkit-1.7.1/lib/sshkit/backends/netssh.rb:54:ininstance_exec’
/usr/local/rvm/gems/ruby-1.9.3-p551/gems/sshkit-1.7.1/lib/sshkit/backends/netssh.rb:54:in
run' /usr/local/rvm/gems/ruby-1.9.3-p551/gems/sshkit-1.7.1/lib/sshkit/runners/parallel.rb:13:inblock (2 levels) in execute’
Tasks: TOP => deploy:assets:backup_manifest
The deploy has failed with an error: Exception while executing as
[email protected]: cp exit status: 126
cp stdout: ruby-1.9.3-p484 is not installed.
To install do: ‘rvm install ruby-1.9.3-p484’
cp: target `installed.\r’ is not a directory
bash: line 1: To: command not found
bash: line 2:
/home/deployer/folder/releases/20150724150527/public/assets/manifest.yml:
Permission denied
cp stderr: Nothing written

Looks like the version of ruby that is expected isn’t installed
(1.9.3-p484)?

Does the user that you are using to deploy (looks like deployer) have
the
correct access and permissions to the destination for your deployment?
The
user used for the deployment is the one that needs access to the correct
version of ruby.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs