Capistrano::ConnectionError

Hi. Wondering if anyone can help me with this error meassage i receive
when running cap deploy on my project…

  • executing `deploy’
  • executing `deploy:update’
    ** transaction: start
  • executing `deploy:update_code’
  • executing “svn checkout -q -r1 svn://.*.***.*/meechu/trunk
    /var/www/apps/meechu/releases/20080318133013 && (echo 1 >
    /var/www/apps/meechu/releases/20080318133013/REVISION)"
    servers: ["
    .***.***.***”]
    *** [deploy:update_code] rolling back
  • executing “rm -rf /var/www/apps/meechu/releases/20080318133013;
    true”
    servers: [".*.***.***"]
    ** [deploy:update_code] exception while rolling back:
    Capistrano::ConnectionError, connection failed for: .*.***.***
    (Errno::EACCES: Permission denied - /tmp/ssh-sShjJP6258/agent.6258)

I ran capistrano last night setp, deploy, start and everything worked
fine. The folder structure was set up and everything ran fine. This
morning i make some changes to the app and run cap deploy again and got
this error.

Thankyou in advance
Jim

Sorry all… i was deploying from the wrong local account. all my ssh
stuff was set up in another account DOH!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs