Capistrano => can't create tunnel error


#1

Hello,

I’m trying to use capistrano deployment on my mediatemple DV server.
Unfortunately I always get the same “can’t create tunnel” error when
doing “cap deploy”. I’ve been searching for a solution but it’s really
driving me nuts. With tortoise (svn+ssh) I’m able to connect to my
repository without any problems. Can somebody help me?

D:\webroot\mezza_svn>cap deploy

  • executing task deploy
  • executing task update
    ** transaction: start
  • executing task update_code
  • querying latest revision…
    svn: Can’t create tunnel: The system cannot find the file specified.
    *** [update_code] transaction: rollback
  • [update_code] rolling back
  • executing “rm -rf /u/apps/mezza/releases/20070709160041”
    servers: [“www.mezza-interieur.be”]
    Password: xxx

** [update_code] exception while rolling back:
Net::SSH::AuthenticationFailed,
Owner
c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.4.1/lib/capistrano/scm/subversion.rb
:24:in latest_revision': Could not determine latest revision (RuntimeError) from c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.4.1/lib/capistrano/conf iguration.rb:62:ininitialize’
from
c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.4.1/lib/capistrano/conf
iguration.rb:89:in call' from c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.4.1/lib/capistrano/conf iguration.rb:89:in[]’
from
c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.4.1/lib/capistrano/conf
iguration.rb:236:in method_missing' from c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.4.1/lib/capistrano/scm/ subversion.rb:63:incheckout’
from
c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.4.1/lib/capistrano/reci
pes/standard.rb:80:in load' from c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.4.1/lib/capistrano/acto r.rb:159:ininstance_eval’
from
c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.4.1/lib/capistrano/acto
r.rb:159:in update_code' ... 13 levels... from c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.4.1/lib/capistrano/cli. rb:12:inexecute!’
from c:/ruby/lib/ruby/gems/1.8/gems/capistrano-1.4.1/bin/cap:11
from c:/ruby/bin/cap:16:in `load’
from c:/ruby/bin/cap:16


#2

Do you have a command-line SSH client installed, such as OpenSSH?

  • Jamis

#3

Jamis B. wrote:

Do you have a command-line SSH client installed, such as OpenSSH?

  • Jamis

yes, I’m working with putty. I guess capistrano is trying to connect to
my repository from my local computer.


#4

This is a known problem with putty. One solution is to use cygwin. There
is
also (or used to be) a web page out there somewhere that explained how
to
configure putty and server so this would work, but I can’t find it right
now.

On 7/9/07, Maarten P. removed_email_address@domain.invalid wrote:


Posted via http://www.ruby-forum.com/.

Andrew S. * http://semprebon.blogspot.com/


#5

You might want to check out this article:

http://www.woodwardweb.com/java/000155.html

It’s not cap-specific, but the advice it gives might be applicable,
since the problem is the same.

  • Jamis

#6

Andrew S. wrote:

This is a known problem with putty. One solution is to use cygwin. There
is
also (or used to be) a web page out there somewhere that explained how
to
configure putty and server so this would work, but I can’t find it right
now.

On 7/9/07, Maarten P. removed_email_address@domain.invalid wrote:


Posted via http://www.ruby-forum.com/.

Andrew S. * http://semprebon.blogspot.com/

Ok, I tried several things. Changing the ssh var in the subversion
config file to:
ssh = C:\Program Files\TortoiseSVN\bin\TortoisePlink.exe -ssh -l
cpanelid

didn’t work ;( … I also tried adding an environment variable in
windows. Din’t work eighter.

I’m gonna try cygwin. Hopefully that will work… :slight_smile: Do I have to
uninstall putty first? If this is a common problem, why isn’t there much
information about this? On my other PC I was able to use
capistrano/svn/putty without any problems.


#7

Andrew S. wrote:

I don’t think its that common - maybe its a particular version of putty
and
windows combined or something. I know I tried setting up the config file
with plink.exe and that didn’t work, but I can’t remember if I fixed it
or
not. I ended up going with cygwin.

On 7/9/07, Maarten P. removed_email_address@domain.invalid wrote:

On 7/9/07, Maarten P. removed_email_address@domain.invalid wrote:

uninstall putty first? If this is a common problem, why isn’t there much

Andrew S. * http://semprebon.blogspot.com/

YES!! … I fixed it. I just restarted windows and then svn accepted the
plink ssh client :). jezus, took me hours.


#8

Hi:

Please review my windows recipe below as I have gotten excellent
results with it. Getting cap+svn+ssh to all work together on Windows
is tricky business. Some of the links might be old versions, but this
should point you in the right direction.


Here’s what I do to make a working windows environment.


At this point, everything should work without passwords (svn and
putty).

Good luck,
Bradley Taylor
http://railsmachine.com

On Jul 9, 1:37 pm, Maarten P. removed_email_address@domain.invalid


#9

I don’t think its that common - maybe its a particular version of putty
and
windows combined or something. I know I tried setting up the config file
with plink.exe and that didn’t work, but I can’t remember if I fixed it
or
not. I ended up going with cygwin.

On 7/9/07, Maarten P. removed_email_address@domain.invalid wrote:

On 7/9/07, Maarten P. removed_email_address@domain.invalid wrote:

uninstall putty first? If this is a common problem, why isn’t there much

Andrew S. * http://semprebon.blogspot.com/