Capistrano and Subversion being killed by signal 15

I’m trying to deploy my app with Capistrano but I get what seems to be
an weird error. I have been search the net looking for an answer but it
seems to me that this problem is caused but some kind of combinantion of
versions and few people are getting the error.

However, I will be pleased if anyone can help me.

What I’m trying to do is deploying my app with Capistrano. When I do cap
deploy:setup it runs ok but when I run cap deploy:cold I get this error:

Permission denied, please try again.
Permission denied, please try again.
Permission denied (publickey,password,keyboard-interactive)
svn: connection closed unexpectedly.

The authentication process is ok (I’m nearly sure) because I’ve tried
with a bad pass and an authentication error is raised.

When I try to do the svn checkout localy first I get this message from

killed by signal 15

And nothing happens.
I run the checkout for the second time and the checkout is executed but
it finish with a killed by signal 15 the same way.

So, I think that Capistrano find this signal error from subversion and
stops execution giving that “Permission denied” error above. I don’t
know what to try.

Sorry for the long post.

Any ideas? Do you need any config file? Thanks in advance!

Did you ever solve this problem? I am having a similar problem.
Best regards,

No, I’m sorry, I didn’t. I think you should try to configure the system
to login without a password. I think this problem is due to an
authentication bug.
Please, if you find a solution, post it.