Can't upload files > 10Mb

I’ve got an app that I upload CSV files to. So far it’s worked
flawlessly until yesterday. The CSV files have gotten progressively
larger and yesterday they broke 10Mb. At this point Nginx logs an error
that says:

[error] 6610#0: *67 client intended to send too large body: 11226223
bytes

I’ve got this in my nginx.conf:

client_max_body_size 150m;

What other parameters might affect this?

I tested with 0.6.29 and 0.6.31.

Cliff

Hey Cliff-- I had the same problem a few weeks ago and then realized
that
the “client_max_body_size” parameter wasn’t in the right place. Do you
have
it under a location block?
-tieg

On Thu, 2008-05-15 at 13:01 -0400, Tieg Z. wrote:

Hey Cliff-- I had the same problem a few weeks ago and then realized
that the “client_max_body_size” parameter wasn’t in the right place.
Do you have it under a location block?

It’s in the “http” section. I’ll try adding it to the specific location
block.

Cliff

On Thu, May 15, 2008 at 10:32:56AM -0700, Cliff W. wrote:

On Thu, 2008-05-15 at 13:01 -0400, Tieg Z. wrote:

Hey Cliff-- I had the same problem a few weeks ago and then realized
that the “client_max_body_size” parameter wasn’t in the right place.
Do you have it under a location block?

It’s in the “http” section. I’ll try adding it to the specific location
block.

Is this error still in error_log ?
What is your backend ? It may its own limit.

I found the problem. I was also including the directive in file that
had it set to 10m.

Sorry for the noise.

Cliff

Igor S. wrote:

On Thu, May 15, 2008 at 10:32:56AM -0700, Cliff W. wrote:

On Thu, 2008-05-15 at 13:01 -0400, Tieg Z. wrote:

Hey Cliff-- I had the same problem a few weeks ago and then realized
that the “client_max_body_size” parameter wasn’t in the right place.
Do you have it under a location block?

It’s in the “http” section. I’ll try adding it to the specific location
block.

Is this error still in error_log ?
What is your backend ? It may its own limit.

I have the same problem and I don’t have any explicit “max” setting in
any configuration file. I’m not sure what you mean by “backend” – but I
cast “http”.

[[email protected] /usr/local/etc/nginx]# grep -ri max .
[[email protected] /usr/local/etc/nginx]# grep -ri upload .
[[email protected] /usr/local/etc/nginx]#

Although I read here
https://cloud-support.engineyard.com/discussions/problems/228-nginxpassenger-issue-file-uploads-not-working-client-intended-to-send-too-large-body
that “upload_max_file_size 50m; client_max_body_size 50m;” fix the
problem, my nginx 0.7.61 refuses to accept the former in http { }.

Also, I read from
http://wiki.nginx.org/NginxHttpCoreModule#client_max_body_size that the
default size is 1m. Is it reasonable to specify a maximum by default,
especially this strict?

For giving some context: I stumbled into the problem when people were
reporting that the majority, but not all (“indeterministically”, as they
said) of the Document Uploads in an OpenGoo installation did not work.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs