Can't update and install gem

os:win xp
ruby: ruby 1.9.1p243 (2009-07-16 revision 24175) [i386-mingw32]

I got this error:
Updating RubyGems
ERROR: http://gems.rubyforge.org/ does not appear to be a repository
ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
Errno::ENOTCONN: A request to send or receive data was disallowed
because th
e socket is not connected and (when sending on a datagram socket using a
sendto
call) no address was supplied. (http://gems.rubyforge.org/yaml)

can anyone have a sulotion?
thank u

ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
Errno::ENOTCONN: A request to send or receive data was disallowed

can anyone have a sulotion?

Try it again?
Seems to be working here…

[26:1948][[email protected]:~/dev/allgems]$ gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.3.5
:0:Warning: Gem::SourceIndex#search support for String patterns is
deprecated
Updating RubyGems to 1.3.5
Installing RubyGems 1.3.5
RubyGems 1.3.5 installed

did u try it on linux os?yes it worked on my linux os but when i try it
on win xp os I got an error.

On Jan 27, 3:27 am, Johny ben [email protected] wrote:

sendto
call) no address was supplied. (http://gems.rubyforge.org/yaml)

can anyone have a sulotion?

Please check your browser setting for a proxy, use --http-proxy with
gem install command or set HTTP_PROXY variable with a valid URL of the
proxy.

If that is not the issue, try including the following information in
your report:

“gem env” output
“gem install gemname --debug -V” complete output.

On Jan 28, 2:59 am, Johny ben [email protected] wrote:

configure proxies to access the internet
no proxy server is enable

I attached the output error I got running this command
gem env
gem install rails --debug -V

Attachments:http://www.ruby-forum.com/attachment/4434/error.txt

Can you access this URL from your internet browser?

htttp://gems.rubyforge.org/yaml

If that doesn’t work them something is blocking RubyGems servers from
your computer or network.

Looking at Windows errors for Sockets:

http://msdn.microsoft.com/en-us/library/ms740668(VS.85).aspx

WSAENOTCONN (10057) happens when you don’t have an IP address or
someone (a firewall or an antivirus) is blocking you.

Please verify that none of these tools is locking RubyGems.

Can you access this URL from your internet browser?

htttp://gems.rubyforge.org/yaml

If that doesn’t work them something is blocking RubyGems servers from
your computer or network.

Looking at Windows errors for Sockets:

http://msdn.microsoft.com/en-us/library/ms740668(VS.85).aspx

WSAENOTCONN (10057) happens when you don’t have an IP address or
someone (a firewall or an antivirus) is blocking you.

Please verify that none of these tools is locking RubyGems.

when I type this url on my browser
htttp://gems.rubyforge.org/yaml
I got an error
firefox doesn’t know to open this address

my firewall is disable and I uninstall the antivirus

I got the same prob…

On Jan 28, 9:53 am, Johny ben [email protected] wrote:

WSAENOTCONN (10057) happens when you don’t have an IP address or
someone (a firewall or an antivirus) is blocking you.

Please verify that none of these tools is locking RubyGems.

when I type this url on my browser
htttp://gems.rubyforge.org/yaml
I got an error
firefox doesn’t know to open this address

Perhaps you should try with one less “t” in HTTP

http://en.wikipedia.org/wiki/Hypertext_Transfer_Protocol

my firewall is disable and I uninstall the antivirus

I got the same prob…

I’m running out of options in what could be the root of that error
you’re getting.

Can you please try this in a irb session?

require ‘net/http’
Net::HTTP.get_response(URI.parse(“http://gems.rubyforge.org/yaml”))
Net::HTTP.get_response(URI.parse(“http://production.s3.rubygems.org/
yaml”))

The first get_response should output something like this:
=> #<Net::HTTPFound 302 Found readbody=true>

And the second one:
=> #<Net::HTTPOK 200 OK readbody=true>

If you get an error there, then is something really wrong in your TCP/
IP configuration that blocking you out.

Will need more details about your OS version, if you have adding
privileges and what type of antivirus and firewall software you use.

If that is not the issue, try including the following information in
your report:

“gem env” output
“gem install gemname --debug -V” complete output.
@luis lavena
Thank you for your reply.

on my browser configuration
configure proxies to access the internet
no proxy server is enable

I attached the output error I got running this command
gem env
gem install rails --debug -V

The first get_response should output something like this:
=> #<Net::HTTPFound 302 Found readbody=true>

And the second one:
=> #<Net::HTTPOK 200 OK readbody=true>

If you get an error there, then is something really wrong in your TCP/
IP configuration that blocking you out.

Will need more details about your OS version, if you have adding
privileges and what type of antivirus and firewall software you use.

I already saw the prob.I install rails on 3 different computer,2 got
successful result and 1 got an error.

Here the os info on the one that got an error
microsoft win xp pro
version 200,service pack 2

firewall is disabled
no antivrus installed

irb(main):001:0> require ‘net/http’
=> true
<get_response(URI.parse(“http://gems.rubyforge.org/yaml”))
=> #<Net::HTTPFound 302 Found readbody=true>
<get_response(URI.parse(“http://production.s3.rubygems.org/yaml”))
=> #<Net::HTTPOK 200 OK readbody=true>

On Jan 29, 7:22 am, Johny ben [email protected] wrote:

privileges and what type of antivirus and firewall software you use.

I already saw the prob.I install rails on 3 different computer,2 got
successful result and 1 got an error.

The 3 machines running the same Ruby version?
The 3 machines running the same OS and configuration?

Here the os info on the one that got an error
microsoft win xp pro
version 200,service pack 2

I’m not sure about Windows 2000, haven’t checked it, but I thought SP4
or something like that was the latest Service Pack, correct?

firewall is disabled
no antivrus installed

irb(main):001:0> require ‘net/http’
=> true
<get_response(URI.parse(“http://gems.rubyforge.org/yaml”))
=> #<Net::HTTPFound 302 Found readbody=true>
<get_response(URI.parse(“http://production.s3.rubygems.org/yaml”))
=> #<Net::HTTPOK 200 OK readbody=true>

So if that works, then the issue is something else.

ENOTCONN clearly indicates that could not establish a connection,
maybe slow TCP connection and not waiting the right amount of time.

Please open a ticket on RubyGems Bug Tracker, include “gem env” output
and the gem install --debug -V output too, so developers are able to
investigate it further:

http://rubyforge.org/tracker/?atid=575&group_id=126&func=browse

Apologize for any inconvenience.

In the mean time, you can manually download all the related gems from
gemcutter:

http://gemcutter.org/

And manually install them from a command prompt.


Luis L.

After reinstalling my os xp I finally got successful rails
installation…
I think there is an application installed on my desktop that block my
installation…

Here the what I got:

ruby 1.9.1p243 (2009-07-16 revision 24175) [i386-mingw32]

C:\Documents and Settings\a>gem update --system
Updating RubyGems
Nothing to update

C:\Documents and Settings\a>gem install rails
Successfully installed rake-0.8.7
Successfully installed activesupport-2.3.5
Successfully installed activerecord-2.3.5
Successfully installed rack-1.0.1
Successfully installed actionpack-2.3.5
Successfully installed actionmailer-2.3.5
Successfully installed activeresource-2.3.5
Successfully installed rails-2.3.5
8 gems installed
Installing ri documentation for rake-0.8.7…
Installing ri documentation for activesupport-2.3.5…
Installing ri documentation for activerecord-2.3.5…
Installing ri documentation for rack-1.0.1…
Installing ri documentation for actionpack-2.3.5…
Installing ri documentation for actionmailer-2.3.5…
Installing ri documentation for activeresource-2.3.5…
Installing ri documentation for rails-2.3.5…
Updating class cache with 0 classes…
Installing RDoc documentation for rake-0.8.7…
Installing RDoc documentation for activesupport-2.3.5…
Installing RDoc documentation for activerecord-2.3.5…
Installing RDoc documentation for rack-1.0.1…
Installing RDoc documentation for actionpack-2.3.5…
Installing RDoc documentation for actionmailer-2.3.5…
Installing RDoc documentation for activeresource-2.3.5…
Installing RDoc documentation for rails-2.3.5…

C:\Documents and Settings\a>rails -v
Rails 2.3.5

C:\Documents and Settings\a>gem -v
1.3.5

C:\Documents and Settings\a>ruby -v
ruby 1.9.1p243 (2009-07-16 revision 24175) [i386-mingw32]

Thank you sir for helping my to solved this prob

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs