Can't run ruby after upgrading from 2.0.0-p195 to 2.0.0-p247 using rvm

Team,

I upgraded ruby 2.0.0-p195 to ruby 2.0.0-p247. It looks like everything
went fine but, when I try to run ruby -v or gem -v it fails with the
messages:

ruby -v

ruby: error while loading shared libraries: libruby.so.2.0: cannot open
shared object file: No such file or directory

gem -v

/usr/local/bin/ruby: error while loading shared libraries:
libruby.so.2.0:
cannot open shared object file: No such file or directory

Below is the entire history of the upgrade.

Any help will be apprciated.

Thank you

ruby -v

ruby 2.0.0p195 (2013-05-14 revision 40734) [x86_64-linux]
[root@oc5204722173 victor]# rvm upgrade 2.0.0-p0 2.0.0-p247
Are you sure you wish to upgrade from ruby-2.0.0-p195 to
ruby-2.0.0-p247?
(Y/n): y
Installing new ruby ruby-2.0.0-p247
Searching for binary rubies, this might take some time.
No binary rubies available for: redhat/6.3/x86_64/ruby-2.0.0-p247.
Continuing with compilation. Please read ‘rvm help mount’ to get more
information on binary rubies.
Installing requirements for redhat, might require sudo password.
Requirements installation successful.
Installing Ruby from source to: /usr/local/rvm/rubies/ruby-2.0.0-p247,
this
may take a while depending on your cpu(s)…
ruby-2.0.0-p247 - #downloading ruby-2.0.0-p247, this may take a while
depending on your connection…
% Total % Received % Xferd Average Speed Time Time Time
Current
Dload Upload Total Spent Left
Speed
100 10.3M 100 10.3M 0 0 108k 0 0:01:36 0:01:36 --:–:--
309k
ruby-2.0.0-p247 - #extracting ruby-2.0.0-p247 to
/usr/local/rvm/src/ruby-2.0.0-p247
ruby-2.0.0-p247 - #extracted to /usr/local/rvm/src/ruby-2.0.0-p247
ruby-2.0.0-p247 -
#configuring
ruby-2.0.0-p247 -
#compiling
ruby-2.0.0-p247 -
#installing
Retrieving rubygems-2.0.5
% Total % Received % Xferd Average Speed Time Time Time
Current
Dload Upload Total Spent Left
Speed
100 328k 100 328k 0 0 1013k 0 --:–:-- --:–:-- --:–:--
1413k
Extracting rubygems-2.0.5 …
Removing old Rubygems files…
Installing rubygems-2.0.5 for
ruby-2.0.0-p247…
Installation of rubygems completed successfully.
Saving wrappers to ‘/usr/local/rvm/wrappers/ruby-2.0.0-p247’…

ruby-2.0.0-p247 - #adjusting #shebangs for (gem irb erb ri rdoc testrb
rake).
ruby-2.0.0-p247 - #importing default gemsets, this may take
time…
Install of ruby-2.0.0-p247 - #complete
Migrating gems from ruby-2.0.0-p195 to ruby-2.0.0-p247
Are you sure you wish to MOVE gems from ruby-2.0.0-p195 to
ruby-2.0.0-p247?
This will overwrite existing gems in ruby-2.0.0-p247 and remove them
from
ruby-2.0.0-p195 (Y/n): y
Moving gemsets…
Moving ruby-2.0.0-p195 to ruby-2.0.0-p247
Making gemset ruby-2.0.0-p247 pristine…
Moving ruby-2.0.0-p195@global to ruby-2.0.0-p247@global
Making gemset ruby-2.0.0-p247@global pristine…
Do you wish to move over aliases? (Y/n): y
Do you wish to move over wrappers? (Y/n): y
Do you also wish to completely remove ruby-2.0.0-p195 (inc. archive)?
(Y/n): y
Removing ruby-2.0.0-p195…
Successfully migrated ruby-2.0.0-p195 to ruby-2.0.0-p247
Upgrade complete!
[root@oc5204722173 victor]# ruby -v
ruby: error while loading shared libraries: libruby.so.2.0: cannot open
shared object file: No such file or directory
[root@oc5204722173 victor]# gem -v
/usr/local/bin/ruby: error while loading shared libraries:
libruby.so.2.0:
cannot open shared object file: No such file or directory