Can't run rails application

Hello,

I’m trying to run Rails on Apache 2.0 with mod_fcgid. It seems like
fcgi has been set up ok, but still I can’t run my rails application.
Here is my httpd.conf

IPCCommTimeout 40
IPCConnectTimeout 10
DefaultInitEnv RAILS_ENV production
SocketPath /tmp/fcgidsock

<VirtualHost :80>

RewriteEngine On
RewriteOptions MaxRedirects=3
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.
)$ dispatch.fcgi [QSA,L]

    <Directory /home/vptr/rails/testas/public>
            Options Indexes FollowSymLinks ExecCGI
            AllowOverride None
            Order allow,deny
            Allow from all
            AddHandler fcgid-script .fcgi
    </Directory>

    ServerAdmin [email protected]
    DocumentRoot /home/vptr/rails/testas/public
    ServerName vezlys.lt

There are no errors in http servers’ log files. And here is something
from production.log:

Recognition failed for “/”
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/routing.rb:488:in
recognition_failed' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/routing.rb:478:inrecognize!’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/dispatcher.rb:38:in
dispatch' /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/fcgi_handler.rb:150:inprocess_request’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/fcgi_handler.rb:54:in
process!' /usr/lib/ruby/site_ruby/1.8/fcgi.rb:600:ineach_cgi’
/usr/lib/ruby/site_ruby/1.8/fcgi.rb:597:in each_cgi' /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/fcgi_handler.rb:53:inprocess!’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/fcgi_handler.rb:23:in
`process!’
/home/vptr/rails/testas/public/dispatch.fcgi:24

Any ideas? Thank you for your time.

Tadas

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs