Can't run production console: custom_require.rb:27: [BUG] terminated node (0x8117eb8)


#1

Suddenly I can’t run the production console anymore for my app :(.
Here’s the error I get:

08:12pm fggedsaa:~/rails/production/app>./script/console
production
Loading production environment (Rails 2.1.1)
/opt/csw/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27: [BUG]
terminated node (0x8117eb8)
ruby 1.8.6 (2007-03-13) [i386-solaris2.11]

Version info:

8:24pm fggedsaa:~/rails/production/app> gem -v
1.2.0
8:24pm fggedsaa:~/rails/production/app> ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i386-solaris2.11]
8:24pm fggedsaa:~/rails/production/app> rails -v
Rails 2.1.1

Running the development console works fine. I can’t find any
difference in gem usage between dev and production environments, but
clearly there is one.

Thanks in advance for any help! This is a big problem for me…

David


#2

On Mar 15, 8:26 pm, David M. removed_email_address@domain.invalid wrote:

Suddenly I can’t run the production console anymore for my app :(.
Here’s the error I get:

That is a bug in the ruby interpreter. If I were you I’d try a more
recent version of 1.8.6 (you’re at patch level 0, the current one is
something like 287)

Fred


#3

Fred, Thanks for the info.

And does it make sense that this happens only for me and not other
users?

David

On Mar 15, 5:40 pm, Frederick C. removed_email_address@domain.invalid


#4

On Mar 25, 2:15 pm, David M. removed_email_address@domain.invalid wrote:

Fred, Thanks for the info.

And does it make sense that this happens only for me and not other
users?

Dunno - Doubt anyone is still running that patch level of 1.8.6. Bugs
aren’t always predictable.

Fred