Can't Install VisualRuby


#1

Hi, this is my first post in the forums, so forgive me if this is in a
wrong place.

My problem is, I can’t install visualruby because, gtksourceview2 gem
fails to install, attached is error message produced.

I already have it installed and running about a year ago, and I decided
to delete all my rubies and start fresh again. And now, I can’t install
it anymore.

I’m running Windows XP 32-bit.
I also installed the GTK in the Visualruby.net website.

Ruby Version
ruby 1.9.3p551 (2014-11-13) [i386-mingw32]

Installed GEMS
atk (2.2.5 x86-mingw32)
bigdecimal (1.1.0)
bundler (1.10.1)
cairo (1.14.1 x86-mingw32)
gdk_pixbuf2 (2.2.5 x86-mingw32)
glib2 (2.2.5 x86-mingw32)
gtk2 (2.2.5 x86-mingw32)
io-console (0.3)
json (1.5.5)
minitest (2.5.1)
pango (2.2.5 x86-mingw32)
pkg-config (1.1.6)
rake (0.9.2.2)
rdoc (3.9.5)
require_all (1.3.2)
rubygems-update (2.4.7)
vrlib (1.0.16)


#2

Solved it. Use version 2.1.0 of gtksourceview2 gem and it will work
fine.


#3

Hi,

One first post deserves another!

Did you actually manage to run visualruby?

I had the same problem as you, and used your suggestion. This allowed me
to install vr successfully, however, when it comes to run I get
following error:

C:\Documents and Settings\Owner>vr
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require’: cannot load such file – cairo.so (LoadError)

etc…

I am using the same setup:
Windows XP
ruby 1.9.3

Gems:
atk (2.2.5 x86-mingw32, 2.1.0 x86-mingw32)
bigdecimal (1.1.0)
cairo (1.14.1 x86-mingw32)
gdk_pixbuf2 (2.2.5 x86-mingw32, 2.1.0 x86-mingw32)
glib2 (2.2.5 x86-mingw32, 2.1.0 x86-mingw32)
gtk2 (2.2.5 x86-mingw32, 2.1.0 x86-mingw32)
gtksourceview2 (2.1.0 x86-mingw32)
io-console (0.3)
json (1.5.5)
minitest (2.5.1)
pango (2.2.5 x86-mingw32, 2.1.0 x86-mingw32)
pkg-config (1.1.6)
rake (0.9.2.2)
rdoc (3.9.5)
require_all (1.3.2)
visualruby (1.0.16)
vrlib (1.0.16)


#4

Hi!

Try to upgrade to Ruby 2.0.0 or higher. The latest cairo gem dropped
support for 1.9.3.

For reference:
https://www.ruby-forum.com/topic/44870501

Also, try and uninstall version 2.2.5 of the gems because visualruby
will try to load the latest version.