Can't install typo


#1

Hello,

I try install typo, on my local machine, after set database config, i
try start application and get fallowing error:

/usr/local/lib/site_ruby/1.8/rubygems.rb:149:in activate': can't activate actionpack (= 1.13.6, runtime), already activated actionpack-2.2.2 (Gem::Exception) from /usr/local/lib/site_ruby/1.8/rubygems.rb:165:inactivate’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:164:in each' from /usr/local/lib/site_ruby/1.8/rubygems.rb:164:inactivate’
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:35:in require' from /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:inrequire’
from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
new_constants_in' from /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:inrequire’
from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:256:in
require_frameworks' from /var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:256:ineach’
from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:256:in
require_frameworks' from /var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:133:inprocess’
from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in send' from /var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:inrun’
from /home/darius/workspace/github/typo/config/environment.rb:19
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
require' from /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:innew_constants_in’
from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
require' from /var/lib/gems/1.8/gems/rails-2.2.2/lib/commands/servers/webrick.rb:59 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in require' from /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:inrequire’
from
/var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
new_constants_in' from /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:inrequire’
from
/var/lib/gems/1.8/gems/rails-2.2.2/lib/commands/server.rb:49
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from script/server:3

it seems like problem with actionpack, i have installed fallowing
versions actionpack 2.2.2, 2.0.2, 1.13.6
maybe someone know how to fix it ?


#2

Hi there,

I am trying to figure out the exact same problem here.

I tried to run “rake db:migrate” and get similar issues.

I tried to get rid of old versions of gems by “sudo gem cleanup” which
solved the problem you are having right now just to run into the next
problem. Try this first and please let me know on this list if this
resolved
it for you.

Thanks,

Tobias


#3

cleanup doesn’t help, but thank you, you put me on the right way :slight_smile: ,
problem is because lastest actionwebservice from gems depends on
ationpack 1.13.6, activerecord 1.15.6 and activesupport 1.4.4

i install actionwebservice from github ant its work :slight_smile:


#4

Darius wrote:

cleanup doesn’t help, but thank you, you put me on the right way :slight_smile: ,
problem is because lastest actionwebservice from gems depends on
ationpack 1.13.6, activerecord 1.15.6 and activesupport 1.4.4

i install actionwebservice from github ant its work :slight_smile:

Me too. I got actionwebservice from github and extract that file and
rename actionwebservice but it not works. Here is what i process to
install manually.

  1. Extract the latest actionwebservice.zip
  2. Put it in to C:\xxxx\ruby\lib\ruby\gems\1.8\gems and
    actionwebservice.gemspec into
    C:\xxxx\ruby\lib\ruby\gems\1.8\specifications.
  3. Gem install actionwebservice.

… then i have still got the same problem with actionwebservice-1.2.6
from console.

How can i update the latest one please?


#5

did you install this
http://github.com/datanoise/actionwebservice/tree/master ?

in my setup gem list --local show this:
datanoise-actionwebservice (2.2.2)


#6

For info, check this post for news about Typo:
http://harryseldon.thinkosphere.com/2009/03/08/news-from-typo-edge