Can't Install Ruby Builder


#1

Pretty new to ruby and trying to install Builder but not having much
luck. If I try to install it via the RubyGems Package Manager I get the
problem shown in the below image. Basically it says it installs, but
gives an error for installing the ri documentation. If I try to require
builder after this I get an error saying there is no such file to load.
Not really sure what to do to get around this problem, so any help would
be much appreciated.

Thanks,
Marc

http://rubyforge.org/projects/builder/

http://img19.imageshack.us/img19/982/errormessageh.png


#2

Thanks a ton for the tips. However, despite it saying builder is
installed I still get the same issue when I try to require builder. No
idea what I’m doing wrong. The error is as follows:

C:/Ruby/programs/xmltest.rb:1:in `require’: no such file to load –
builder (LoadError)
from C:/Ruby/programs/xmltest.rb:1


#3

Marc Ch wrote:

http://img19.imageshack.us/img19/982/errormessageh.png

Tip: Use the context menu (the “right” mouse button) on the icon in the
upper
left corner of the CMD.EXE program. Find Preferences, and turn something
like
Quick Edit on. Save the Preference to leave it turned on.

Then drag-select that text. Programmers must do this all the time, and
it should
not be hard!

Tip 2: Use Console2! http://sourceforge.net/projects/console/

Tip 3: You already have Builder - just start using it. The error message
is
about its ‘ri’ entry, which is obsolete technology for people without
ubiquitous
WiFi access to Google.


#4

That helped, thanks a ton!


#5

On Mar 16, 3:54 am, Heesob P. removed_email_address@domain.invalid wrote:

   from C:/Ruby/programs/xmltest.rb:1

First check the environment variable “RUBYOPT” with “echo %RUBYOPT%”.
If you installed OCI ruby properly, it must be “-rubygems”.

If it is not “-rubygems”, you can set it by “set RUBYOPT=-rubygems”.
Or insert "require ‘rubygems’ " before require ‘builder’ will work for you.

I’ll suggest not set RUBYOPT at all and instead use ‘require
“rubygems”’ in your script prior requiring builder.

The new One-Click Installer does not set RUBYOPT at all, since it only
has proven to put more differences between Linux and Windows users
than help out new comers.


#6

Hi,

2009/3/16 Marc Ch removed_email_address@domain.invalid:

Thanks a ton for the tips. Â However, despite it saying builder is
installed I still get the same issue when I try to require builder. Â No
idea what I’m doing wrong. Â The error is as follows:

C:/Ruby/programs/xmltest.rb:1:in `require’: no such file to load –
builder (LoadError)
    from C:/Ruby/programs/xmltest.rb:1

First check the environment variable “RUBYOPT” with “echo %RUBYOPT%”.
If you installed OCI ruby properly, it must be “-rubygems”.

If it is not “-rubygems”, you can set it by “set RUBYOPT=-rubygems”.
Or insert "require ‘rubygems’ " before require ‘builder’ will work for
you.

Regards,

Park H.