Can't install rmagick

Tried ‘gem install rmagick’

Got


Building native extensions. This could take a while…
ERROR: Error installing rmagick:
ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
checking for Ruby version >= 1.8.5… yes
checking for cc… yes
checking for Magick-config… yes

Warning: Found more than one ImageMagick installation. This could cause
problems at runtime.
/usr/bin//Magick-config reports version 6.3.7 Q16 is installed
in /usr
/usr/bin/Magick-config reports version 6.3.7 Q16 is installed
in /usr
Using 6.3.7 Q16 from /usr.

Warning: Found a partial ImageMagick installation. Your operating system
likely has some built-in ImageMagick libraries but not all of
ImageMagick. This will most likely cause problems at both compile and
runtime.
Found partial installation at: /usr
checking for ImageMagick version >= 6.4.9… no
Can’t install RMagick 2.13.1. You must have ImageMagick 6.4.9 or later.

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=.
–curdir
–ruby=/usr/bin/ruby1.8

Gem files will remain installed in
/usr/local/rvm/gems/ruby-1.9.2-p136/gems/rmagick-2.13.1 for inspection.
Results logged to
/usr/local/rvm/gems/ruby-1.9.2-p136/gems/rmagick-2.13.1/ext/RMagick/gem_make.out

I remember I had problem installing it locally a while ago. Can’t
remember what I did.

Any ideas?

[ OT: Just amazing how it can be like this. Sorry, but how can people
accept this crap. So many sitting to find the right answer. Something is
wrong with the whole developer thing.

Is it just me or are there others who feel it’s become more complex,
with more problems with the latest rails? I know, I know, rvm has it’s
positive sides, rmagick and rails are two different things, and so on,
but…]

Installing latest IM. Hopefully that will solve it.

Just to add my two cents:

I am using Ubuntu 10.04. I followed following steps to get “rmagick” to
install properly.

  1. Used Synaptic and removed following packages by selecting… “Mark
    for complete removal”
  • graphicsmagick
  • imagemagick
  • associated development libraries (searched for imagemagick-deve)
  1. Re-installed libmagick+±dev which installed all other dependencies.
  2. Tried installing “rmagick” and this time got success.

Please let me know, if this worked for you.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs