Can't install RMagick due to MagickWand problems

Hello,

I’m trying to install/update rmagick on a Debian machine using:
gem install --local rmagick-2.10.0.gem

and get following error:
/usr/local/bin/ruby extconf.rb install --local rmagick-2.10.0.gem
checking for Ruby version >= 1.8.5… yes
checking for gcc… yes
checking for Magick-config… yes

Warning: Found more than one ImageMagick installation. This could cause
problems at runtime.
/usr/bin/Magick-config reports version 6.5.4-0 is installed in
/usr
/usr/bin/X11/Magick-config reports version 6.5.4-0 is installed
in /usr
Using 6.5.4-0 from /usr.

checking for ImageMagick version >= 6.3.5… yes
checking for HDRI disabled version of ImageMagick… yes
checking for stdint.h… yes
checking for sys/types.h… yes
checking for wand/MagickWand.h… no

Can’t install RMagick 2.10.0. Can’t find MagickWand.h.
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

But want is installed:
:/usr/local/include/ImageMagick# ls -la
insgesamt 24
drwxr-sr-x 6 root staff 4096 2009-07-03 15:23 .
drwxrwsr-x 10 root staff 4096 2009-06-27 18:50 …
drwxr-sr-x 2 root staff 4096 2009-06-27 19:27 bin
drwxr-sr-x 3 root staff 4096 2009-06-27 19:21 include
drwxr-sr-x 4 root staff 4096 2009-06-27 19:27 lib
drwxr-sr-x 5 root staff 4096 2009-06-27 19:21 share
lrwxrwxrwx 1 root staff 55 2009-07-03 15:23 wand ->
/usr/local/include/ImageMagick/include/ImageMagick/wand

Anyone knows what’s wrong there?

checking for Magick-config… yes
checking for HDRI disabled version of ImageMagick… yes
But want is installed:

Anyone knows what’s wrong there?

Posted viahttp://www.ruby-forum.com/.

try

sudo apt-get install libmagickcore-dev libmagickwand-dev

?

Works, thanks!

try

sudo apt-get install libmagickcore-dev libmagickwand-dev

?

It worked for me too, man! Thanks!

Ubuntu 11.04
Ruby 1.9.3
Rails 3.2.3

I had the same problem today…
Solved with:

apt-get -y install libmagick9-dev

Parra

On Fri, Jul 3, 2009 at 10:28 AM, Heinz S. <

I am getting same error for windows please anybody will help me.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs