Can't install rails. gem zlib crc error

hi all

i’m trying to install ruby on rails on my debian server. i didn’t use
apt-get. i installed everything from source. i used this tutorial
(without PD-Admin):
http://railswiki.de/Ruby_on_Rails_auf_einem_Debian_Server_installieren

now i can’t install rails over gem, i’m getting this zlib crc error:

[email protected]:~# gem install rails --include-dependencies --verbose –
backtrace
INFO: gem install -y is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list
ERROR: While executing gem … (Zlib::GzipFile::CRCError)
invalid compressed data – crc error
/usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:508:in close' /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:508:ininitialize’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:445:in
each_entry' /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:439:inloop’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:439:in
each_entry' /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:424:ineach’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:485:in
initialize' /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:582:innew’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:582:in
open_from_io' /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:802:inopen_from_io’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/format.rb:69:in from_io' /usr/local/lib/ruby/site_ruby/1.8/rubygems/format.rb:52:infrom_file_by_path’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:
104:in find_gems_with_sources' /usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb: 103:ineach’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:
103:in find_gems_with_sources' /usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb: 196:ingather_dependencies’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:
195:in each' /usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb: 195:ingather_dependencies’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:
91:in initialize' /usr/local/lib/ruby/site_ruby/1.8/rubygems/commands/ install_command.rb:69:innew’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/commands/
install_command.rb:69:in execute' /usr/local/lib/ruby/site_ruby/1.8/rubygems/commands/ install_command.rb:67:ineach’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/commands/
install_command.rb:67:in execute' /usr/local/lib/ruby/site_ruby/1.8/rubygems/command.rb:136:ininvoke’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:104:in
process_args' /usr/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:74:inrun’
/usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:39:in `run’
/usr/local/bin/gem:22

somebody any idea, what the problem is?

thanks in advance!

Hi.

Did you found a solution for this problem?
I got the same problem on debian and searched already a lot for
solutions.

I found only that you may haven’t installed zlib. You can check this
via:

ruby -e “puts(require(‘zlib’))”

true

Unfortunately i get true back, but still got this error. Has anyone a
idea?

Here are my details:

gem env

RubyGems Environment:

  • RUBYGEMS VERSION: 1.1.0 (1.1.0)
  • RUBY VERSION: 1.8.6 (2007-03-13 patchlevel 0) [x86_64-linux]
  • INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.8
  • RUBY EXECUTABLE: /usr/local/bin/ruby
  • RUBYGEMS PLATFORMS:
    • ruby
    • x86_64-linux
  • GEM PATHS:
    • /usr/local/lib/ruby/gems/1.8
  • GEM CONFIGURATION:
    • :update_sources => true
    • :verbose => true
    • :benchmark => false
    • :backtrace => false
    • :bulk_threshold => 1000
  • REMOTE SOURCES:

uname -a

Linux vadmin408 2.6.18-xen #2 SMP Fri Aug 24 20:31:36 CEST 2007 x86_64
GNU/Linux

thx

Hi

yes, you have to install the ruby1.8-dev package from apt-get. this
problems are because of mixing apt-get with rails 2.0…

On 7 Apr., 19:44, Hinnerk G. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs