Can't get SWF player to display in webpage


#1

Found a great link
(http://blog.eleventyten.com/2007/6/8/embedding-swf-content-with-ror/)
describing adding Flash content (in this case playerMultipleList.swf) in
a “rails” webpage.

I’ve followed the instructions to a “T”, however the player doesn’t
display on the page … just the words playerMultipleList.swf appear :frowning:

Everything else is working great after retrofitting the pages to the ROR
framework, but this is one of the most important features. If you have
experience with this and would kindly share it, I will greatly
appreciate it!

Please see attachment for the code I’m using !

Thanks Rubio


#2

On Apr 18, 7:14 pm, Rubio R. removed_email_address@domain.invalid
wrote:

experience with this and would kindly share it, I will greatly
appreciate it!

The path to playerMultipleList.swf looks suspicious to me - if it is
at RAILS_ROOT/public/swf/playerMultipleList.swf then the path to it
(from the browser’s point of view) is just /swf/playerMultipleList.swf
(since the document root should be RAILS_ROOT/public)

Fred


#3

Frederick C. wrote:

On Apr 18, 7:14�pm, Rubio R. removed_email_address@domain.invalid
wrote:

experience with this and would kindly share it, I will greatly
appreciate it!

The path to playerMultipleList.swf looks suspicious to me - if it is
at RAILS_ROOT/public/swf/playerMultipleList.swf then the path to it
(from the browser’s point of view) is just /swf/playerMultipleList.swf
(since the document root should be RAILS_ROOT/public)

Fred

Fred Thanks for the quick reply. I initially had the path as
/swf/playerMultipleList.swf as you suggest, but it didn’t grab the
player in that case either (and I’ve checked and made sure that the
player is in RAILS_ROOT/public/swf. But, theoretically you’re
absolutely right. I’ll keep digging; it’s prob just some little
something I’m not seeing!

Thanks, again
R


#4

Not sure, but some Flash players require not the path, but an absolute
URL, so instead of having:
…/…/…/public/swf/playerMultipleList.swf

you should generate something like:
http://www.theapp.com/swf/playerMultipleList.swf

And also there should be no ‘public’ in the URL.

Dmitry


#5

Dmitry S. wrote:

Not sure, but some Flash players require not the path, but an absolute
URL, so instead of having:
…/…/…/public/swf/playerMultipleList.swf

you should generate something like:
http://www.theapp.com/swf/playerMultipleList.swf

And also there should be no ‘public’ in the URL.

Dmitry

Dmitry - please see the attachment!

It’s working now, but with the path specified simply as
/swf/playerMultipleList.swf. Problem seemed to be an incorrect
swfobject.js. As soon as I copied the original from the download to the
#{RAILS_ROOT}/public/javascripts folder, the player appeared however,
unfortunately there’s still a problem … the tracks don’t appear (get
undefined where a track should be) even though I used the same pathing
convention to point to public/Sounds (should evaluate to
#{RAILS_ROOT}/public/Sounds just as the swf path evaluated to
#{RAILS_ROOT}/public/swf and found the player.

At first I thought this problem would be a piece of cake, but now after
trying the same convention I just mentioned, as well as the relative
path, and absolute path to the myPlayList.xml still just “undefined” for
the track … please see the attachment for a screen shot of this. and
the current code as well.

If you have any ideas, it’s greatly appreciated.

Thanks for your time


#6

Hi Rubio,

Yep, as I remember eiter Flash object, either content should be a
path, and another one should be a URL. So, if the Flash player
requires just a path (/swf/playerMultipleList.swf), then I think that
the content should be provided as a full URL (http://www.theapp.com/
Sounds/song.mp3)

Dmitry

On Apr 21, 11:30 pm, Rubio R. removed_email_address@domain.invalid


#7

Rubio R. wrote:

Dmitry S. wrote:

Not sure, but some Flash players require not the path, but an absolute
URL, so instead of having:
…/…/…/public/swf/playerMultipleList.swf

you should generate something like:
http://www.theapp.com/swf/playerMultipleList.swf

And also there should be no ‘public’ in the URL.

Dmitry

Dmitry - please see the attachment!

It’s working now, but with the path specified simply as
/swf/playerMultipleList.swf. Problem seemed to be an incorrect
swfobject.js. As soon as I copied the original from the download to the
#{RAILS_ROOT}/public/javascripts folder, the player appeared however,
unfortunately there’s still a problem … the tracks don’t appear (get
undefined where a track should be) even though I used the same pathing
convention to point to public/Sounds (should evaluate to
#{RAILS_ROOT}/public/Sounds just as the swf path evaluated to
#{RAILS_ROOT}/public/swf and found the player.

At first I thought this problem would be a piece of cake, but now after
trying the same convention I just mentioned, as well as the relative
path, and absolute path to the myPlayList.xml still just “undefined” for
the track … please see the attachment for a screen shot of this. and
the current code as well.

If you have any ideas, it’s greatly appreciated.

Thanks for your time

Rubio,

I’m having this same problem. I tried relative paths and then an
absolute path http://localhost:3000/public/music/playlist.xml and could
not get it to work. How did you solve this?

Thanks,
Kelly