Can't get gems to work (1.9, Windows)

Hi,

I can’t get gems to work in my 1.9 install. Can anyone help?

The gem command worked (‘gem install log4r’), but when I try to
include it from a script, I just get ‘no such file to load’.

The gem got installed into the directory ‘c:\LAN’. Does that seem
correct?

If I use filemon or procmon while running my script, I notice that
Ruby is only searching the directories under c:\ruby-1.9\lib\ruby.

I’ve tried changing RUBYOPTS, GEM_PATH, GEM_HOME, to no avail.

Jana

On Tue, Apr 1, 2008 at 6:35 PM, [email protected] wrote:

If I use filemon or procmon while running my script, I notice that
Ruby is only searching the directories under c:\ruby-1.9\lib\ruby.

I’ve tried changing RUBYOPTS, GEM_PATH, GEM_HOME, to no avail.

Jana

Ruby Gems seems to have a broken default install-dir in the released
Windows build of 1.9; other comments I’ve seen suggest that using an
explicit --install-dir pointing to the right directory should solve
that problem.

On Wed, Apr 2, 2008 at 4:25 AM, [email protected] wrote:

Ruby Gems seems to have a broken default install-dir in the released
Bulk updating Gem source index for: http://gems.rubyforge.org
library are:

lib\ruby\site_ruby
lib\ruby\vendor_ruby
lib\ruby\1.9.0

How do I get it to search the gems directory?

That’s odd. I think my Ruby 1.9.0-on-Windows-fu has been exhausted
(I just remember the problem with installing gems into the wrong
directory
and the fix; I remember running into enough quirks that I decided to
restrict
myself to 1.8 until there is a 1.9 One-Click-Installer, or at least a
new release
of 1.9 for Windows.)

On Apr 2, 1:24 am, Christopher D. [email protected] wrote:

that problem.
Hi Christopher, thank-you.

I can use --install-dir to force gem to install into the proper place,
but ruby still doesn’t find the gem when I run my script:

\ruby-1.9\bin\gem.bat install --install-dir c:\ruby-1.9\lib\ruby\gems\1.9.0 log4r
Bulk updating Gem source index for: http://gems.rubyforge.org
Successfully installed log4r-1.0.5
1 gem installed
Installing ri documentation for log4r-1.0.5…
Installing RDoc documentation for log4r-1.0.5…

\ruby-1.9\bin\ruby -e “require ‘log4r’”
-e:1:in require': no such file to load -- log4r (LoadError) from -e:1:in

Filemon tells me that the only places that ruby is searching for the
library are:

lib\ruby\site_ruby
lib\ruby\vendor_ruby
lib\ruby\1.9.0

How do I get it to search the gems directory?

Jana

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs