Cant find openssl

OS:redhat 5.6

nginx version=nginx-0.8.54

getting following error

checking for OpenSSL library … not found

./configure: error: SSL modules require the OpenSSL library.
You can either do not enable the modules, or install the OpenSSL library
into the system, or build the OpenSSL library statically from the source
with nginx by using --with-openssl= option.

openssl is installed
-bash-3.2# which openssl
/usr/bin/openssl

openssl-devel is as well

which lib is it looking forward?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,183476,183476#msg-183476

also seeing this in objs/autoconf.err

gcc: unrecognized option ‘-R/lib64/’

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,183476,183481#msg-183481

Hello!

On Thu, Mar 17, 2011 at 09:51:45AM -0400, c_saunders wrote:

into the system, or build the OpenSSL library statically from the source
with nginx by using --with-openssl= option.

openssl is installed
-bash-3.2# which openssl
/usr/bin/openssl

openssl-devel is as well

which lib is it looking forward?

nginx looks for openssl/ssl.h header and libssl and libcrypto
libraries.

Use something like

./configure --with-cc-opt="-I /path/to/include" --with-ld-opt="-L
/path/to/lib"

if you don’t have these available to compiler by default.

Maxim D.

well this is off topic a bit, but this might all be a moot point. We are
putting nginx in front of apache for drupal implementation.
One requirement is SSO via apache auth_ntlm_windbind, for ntlm against
AD. Nginx does not support keepalive as apache does? So it will not be
able to utlize NTLM?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,183476,183507#msg-183507

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs