Can't connect ot MySQL with YourSQL

Ok, this seems silly, but I can’t connect to mysql from yoursql.
I think I have all the privileges set. I can definitly connect via
the command line, but not via yoursql.

Any hints?

mysql> show grants for ‘root’@‘localhost’;
±----------------------------------------------------------------------------------------------------------------------------+
| Grants for [email protected]
|
±----------------------------------------------------------------------------------------------------------------------------+
| GRANT ALL PRIVILEGES ON . TO ‘root’@‘localhost’ IDENTIFIED BY
PASSWORD ‘*6C69D17939B2C1D04E17A96F9B29B284832979B7’ WITH GRANT OPTION
|
±-----------------------------------------------------------------------------------------------------------------------------+

YourSQL - 1.8.0e
MySQL - mysql-standard-5.0.18-osx10.4-powerpc

Thanks


Jim F.

Is ur database sever is in same machine?

Rgds,
–Siva J.
http://www.varcasa.com/
My First Rails Project. Powered by Typo and soon by RForum too

On 1/31/06, Siva J. [email protected] wrote:

Is ur database sever is in same machine?

Yes. All same machine - OS X 10.4. The YourSQL docs say
that it connects via TCP, even when on localhost. I am assuming
that my grant tables permit my machine to connect, but I am
probably wrong here. Problem is, if something needs to change,
I’m not sure what that is yet.


Jim F.

could u try to connect using command prompt

mysql -u root -p

If this works then it must be something to do with yoursql config

On 1/31/06, Jim F. [email protected] wrote:


Jim F.


Rails mailing list
[email protected]
http://lists.rubyonrails.org/mailman/listinfo/rails

Rgds,
–Siva J.
http://www.varcasa.com/
My First Rails Project. Powered by Typo and soon by RForum too

Could it be the new style password hashes? If you are using the new-
style hashes, e.g. in MySQL v5, and YourSQL hasn’t been updated for
them, then that could be the problem. I know I have to use a
particular version of CocoaMySQL to be able to connect because of the
new hashes.

On 1/31/06, Siva J. [email protected] wrote:

could u try to connect using command prompt

mysql -u root -p

If this works then it must be something to do with yoursql config

I connect just fine from the command line. There are only two
preferences with YourSQL and username/pass are the same as
from the commandine. It may be YourSQL, but I think it is the
privileges table.

Rails mailing list
[email protected]
http://lists.rubyonrails.org/mailman/listinfo/rails


Jim F.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs