Can't compile

Hello

When compiling ruby from svn trunk, I get:

/home/cpet2308/privat/DivRubyTing/ruby-clean/tool/instruction.rb:1318:in
encode': transcoding not supported (from ASCII-8BIT to ISO-8859-1) (ArgumentError) from /home/cpet2308/privat/DivRubyTing/ruby-clean/tool/instruction.rb:1318:inwrite’
from
/home/cpet2308/privat/DivRubyTing/ruby-clean/tool/instruction.rb:1318:in
puts' from /home/cpet2308/privat/DivRubyTing/ruby-clean/tool/instruction.rb:1318:inblock (2 levels) in generate’
from
/home/cpet2308/privat/DivRubyTing/ruby-clean/tool/instruction.rb:1318:in
open' from /home/cpet2308/privat/DivRubyTing/ruby-clean/tool/instruction.rb:1318:inblock in generate’
from
/home/cpet2308/privat/DivRubyTing/ruby-clean/tool/instruction.rb:1316:in
each' from /home/cpet2308/privat/DivRubyTing/ruby-clean/tool/instruction.rb:1316:ingenerate’
from ./tool/insns2vm.rb:14:in `’
make: *** [optinsn.inc] Fejl 1

I’m running Debian unstable.

I tried to change my LANG to da_DK.UTF-8, but got the same problem, only
with “transcoding not supported (from ASCII-8BIT to UTF-8)…”

I also tried to change the default locale of my system to da_DK.UTF-8,
but same error.

Anybody else seeing this?

  • Chr.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs