Can't activate activerecord since already activated


#1

=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.1.2 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Exiting
C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:319:in
acti vate': can't activate activerecord (= 2.0.2), already activated activerecord-2.1 .2] (Gem::Exception) from C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/cu stom_require.rb:31:inrequire’
from
C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/activesup
port/lib/active_support/dependencies.rb:510:in require' from C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/activesup port/lib/active_support/dependencies.rb:355:innew_constants_in’
from
C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/activesup
port/lib/active_support/dependencies.rb:510:in require' from C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/activerec ord/lib/active_record.rb:44 from C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/cu stom_require.rb:27:ingem_original_require’
from
C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/cu
stom_require.rb:27:in require' from C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/activesup port/lib/active_support/dependencies.rb:510:inrequire’
… 35 levels…
from
C:/svs/InstantRails-2.0-win/rails_apps/trunk/vendor/rails/railties/
lib/commands/server.rb:39
from
C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/cu
stom_require.rb:27:in gem_original_require' from C:/svs/InstantRails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/cu stom_require.rb:27:inrequire’
from script/server:3

As given i tried “gem cleanup” though it cleaned the already installed
gems it gives the same error as above…

Could anyone help me out???


#2

check installed gems, frozen rails in vendor and environment-entry for
matching version.

which rails version do you intend to use?