Cannot run second rails app in second domain (in vps)


#1

Hi for everyone.
I have a problem with my vps and my app in rails.
A few months I constructed an app with rails, in my vps, the application
is
working fine, without any problem, i working with a version 4.0 and the
version for ruby is 1.9.3.
In a second domain, i installed the same version for both (ruby and
rails),
and run the application without any problem, in port 3000(the first is
in
3005) but when i try to load in my browser, nothing happened ( run the
app
in this way : www.mydomain.com:3000 ), no load,no showing error in my
ssh
client.What’s going on?.
I thought that my app was wrong, that’s why delete the folder and build
a
new blank rails project, but when i run ( my domain is
www.mydomain.com/app:3000) nothing happen, not load the website.

What can be the problem?


#2

On Sat, Dec 21, 2013 at 5:34 AM, Fernando Segura Gmez
removed_email_address@domain.invalid wrote:

new blank rails project, but when i run ( my domain is
www.mydomain.com/app:3000) nothing happen, not load the website.

What can be the problem?

How about you provide more information on the server operating system
and distribution and the hosting provider. We can’t magically guess
these diagnostically relevant pieces of information that would let us
know if it’s your fault for misconfiguring or if we should point you
in other directions.


#3

Can you access it locally on your vps? I would give a try with something
like curl or lynx (both text based accsess). Run one of them from a
terminal and see if you can get the initial root page whatever that is.
If that works you have a communication problem (firewall maybe). If it
does not work look in your logs.

Norm