Cannot load such file -- unicode (LoadError)

I’m new to RoR and working on a migration of project developed by
another
team.
I’m using Rails version (3.2.13) and my bundle install works
successfully.
However while running “rails server”, I get the error below.

btw, I’m using Windows 7 and unicode (0.4.4). Is that the correct
version
for Windows 7 ?

Any suggestions are most appreciated.

Thanks!

-------------- rails server output --------------

C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/activesupport-3.2.
13/lib/active_support/dependencies.rb:251:in require': cannot load such file -- unicode (LoadError) from C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/activ esupport-3.2.13/lib/active_support/dependencies.rb:251:inblock in
require’
from
C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/activ
esupport-3.2.13/lib/active_support/dependencies.rb:236:in
load_dependency' from C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/activ esupport-3.2.13/lib/active_support/dependencies.rb:251:inrequire’
from
C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/fog-1
.16.0/lib/fog/aws.rb:4:in <top (required)>' from C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/activ esupport-3.2.13/lib/active_support/dependencies.rb:251:inrequire’
from
C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/activ
esupport-3.2.13/lib/active_support/dependencies.rb:251:in block in require' from C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/activ esupport-3.2.13/lib/active_support/dependencies.rb:236:inload_dependency’
from
C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/activ
esupport-3.2.13/lib/active_support/dependencies.rb:251:in require' from C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/fog-1 .16.0/lib/fog.rb:9:in<top (required)>’
from
C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundl
er-1.3.5/lib/bundler/runtime.rb:72:in require' from C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundl er-1.3.5/lib/bundler/runtime.rb:72:inblock (2 levels) in require’
from
C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundl
er-1.3.5/lib/bundler/runtime.rb:70:in each' from C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundl er-1.3.5/lib/bundler/runtime.rb:70:inblock in require’
from
C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundl
er-1.3.5/lib/bundler/runtime.rb:59:in each' from C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundl er-1.3.5/lib/bundler/runtime.rb:59:inrequire’
from
C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundl
er-1.3.5/lib/bundler.rb:132:in require' from C:/Projects/zengine1/ninja/config/application.rb:13:in<top
(requi
red)>’
from
C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/railt
ies-3.2.13/lib/rails/commands.rb:53:in require' from C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/railt ies-3.2.13/lib/rails/commands.rb:53:inblock in <top (required)>’
from
C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/railt
ies-3.2.13/lib/rails/commands.rb:50:in tap' from C:/software/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/railt ies-3.2.13/lib/rails/commands.rb:50:in<top (required)>’
from script/rails:6:in require' from script/rails:6:in

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs