Cannot load file

Hi,

I have just installed Watir, devkit & Ruby 2. I am running into an
issue with Watir. Can anyone please let me know how to resolve this
issue?

irb(main):002:0> browser=Watir::Browser.new
LoadError: cannot load such file – watir-classic
from
C:/Ruby200/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in
require' from C:/Ruby200/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:inrequire’
from
C:/Ruby200/lib/ruby/gems/2.0.0/gems/watir-4.0.2/lib/watir/loader.rb
:48:in load_driver' from C:/Ruby200/lib/ruby/gems/2.0.0/gems/watir-4.0.2/lib/watir/loader.rb :40:inload_driver_for’
from
C:/Ruby200/lib/ruby/gems/2.0.0/gems/watir-4.0.2/lib/watir/loader.rb
:8:in new' from (irb):2 from C:/Ruby200/bin/irb:12:in

I’m not sure whether watir works with Ruby 2.0. Have you tried it with
1.9.3?

Joel P. wrote in post #1099074:

I’m not sure whether watir works with Ruby 2.0. Have you tried it with
1.9.3?

Yeah, that’s what I ended up with and works fine with 1.9.3

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs