Cannot load engines plugin/scaffold broke

from C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_suppo
rt/dependencies.rb:214:in `require’
from script/plugin:3

I get the above error.

Also, I cannot get scaffold to work.

I installed ruby182-15 and did a gem rails

I am using Windows XP

Thanks

Frank

Is that the entirety of the error message? Sounds like something’s
gone quite wrong with your Rails/Ruby install…

  • james

I’ve no idea what’s causing that. I suggest you reinstall your Rails
gems…

  • james

hi
heres the whole dump
E:\Eclipse_Projects\mogene_internal>ruby script/plugin install engines
script/plugin: No such file or directory - svn --version
script/plugin: No such file or directory - svn ls
http://dev.rubyonrails.com/svn
/rails/plugins/
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:313:in
plugin s': private methodsplit’ called for nil:NilClass (NoMethodError)
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:3
21:in each' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:2 38:infind_plugin’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:2
37:in each' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:2 37:infind_plugin’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:6
96:in parse!' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:6 92:ineach’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:6
92:in parse!' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:4 11:inparse!’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:4
27:in parse!' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:8 23 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inre
quire__’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in re quire' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_suppo rt/dependencies.rb:214:inrequire’
from script/plugin:3
anyone has a say??
thnx
shodhan

I’m getting the exact same error when trying to install engines. Running
Ruby 1.8.2. Tried reinstalling gems but it still does this. Any other
ideas? I’m most interested in getting the user and login engines to
work.

C:\webruby\testproject>ruby script/plugin install engines
script/plugin: No such file or directory - svn --version
script/plugin: No such file or directory - svn ls
http://dev.rubyonrails.com/svn
/rails/plugins/
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:313:in
plugin s': private methodsplit’ called for nil:NilClass (NoMethodError)
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:3
21:in each' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:2 38:infind_plugin’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:2
37:in each' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:2 37:infind_plugin’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:6
96:in parse!' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:6 92:ineach’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:6
92:in parse!' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:4 11:inparse!’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:4
27:in parse!' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:8 23 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inre
quire__’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in re quire' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_suppo rt/dependencies.rb:214:inrequire’
from script/plugin:3

To install using the script/plugin helper that comes with Rails you
appear to need SVN. Have you installed that?

  • james

On 1/30/06, Brandon P. [email protected] wrote:

c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:313:in
37:in `each’
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:6
from

Posted via http://www.ruby-forum.com/.


Rails mailing list
[email protected]
http://lists.rubyonrails.org/mailman/listinfo/rails

  • J *
    ~

Ah, no I haven’t. Where can I get SVN?

James A. wrote:

To install using the script/plugin helper that comes with Rails you
appear to need SVN. Have you installed that?

  • james

Google is your best friend and will be happy to answer this question…
:slight_smile:

On 1/30/06, Brandon P. [email protected] wrote:


Rails mailing list
[email protected]
http://lists.rubyonrails.org/mailman/listinfo/rails

  • J *
    ~

Do you have subversion installed?


http://www.snowblink.co.uk/

Google lists http://subversion.tigris.org/ as the first response.

On Monday, January 30, 2006, at 11:24 PM, Brandon P. wrote:


Rails mailing list
[email protected]
http://lists.rubyonrails.org/mailman/listinfo/rails

Cheers!
–Dave.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs