Cannot install wxruby on Leopard

I’d like to try wxruby on my MacBook Pro with Leopard (10.5.1)

But I have troubles with gem.

I can see the gem is in rubyforge:

$ gem list wxruby -r

*** REMOTE GEMS ***

wxruby (1.9.2, 1.9.1, 1.9.0)
wxrubylayouts (0.0.3, 0.0.2, 0.0.1)

but when I try to install it:

$ sudo gem install wxruby -r
Password:
ERROR: could not find wxruby locally or in a repository

Any suggestion?
Thanks in advance

Hello Claudio,

First off, what version of RubyGems do you have installed? If you have
0.9.3, try updating to 1.0.3 by doing gem update --system, this will
cause
RubyGems to update itself to the latest version of RubyGems, which I
belive
is 1.0.3, and allow you to install wxruby 1.9.2.

L8ers,

Mario S.

Hello Mario

First, thanks for your suggestion

First off, what version of RubyGems do you have installed? If you have
0.9.3, try updating to 1.0.3 by doing gem update --system, this will
cause RubyGems to update itself to the latest version of RubyGems, which I
belive is 1.0.3, and allow you to install wxruby 1.9.2.

I had version 1.0.1 of gem, since I had updated it recently.

$ gem --version
1.0.1

but as you suggested, I updated gem as well:

$ sudo gem update --system
Password:
Updating RubyGems…
Updating metadata for 40 gems from http://gems.rubyforge.org

complete
Attempting remote update of rubygems-update
Successfully installed rubygems-update-1.0.1
1 gem installed
Updating version of RubyGems to 1.0.1
Installing RubyGems 1.0.1
install -c -m 0644 rbconfig/datadir.rb
/Library/Ruby/Site/1.8/rbconfig/datadir.rb
install -c -m 0644 rubygems/builder.rb
/Library/Ruby/Site/1.8/rubygems/builder.rb
install -c -m 0644 rubygems/command.rb
/Library/Ruby/Site/1.8/rubygems/command.rb
… (I omit part of the log) …
install -c -m 0644 rubygems/version.rb
/Library/Ruby/Site/1.8/rubygems/version.rb
install -c -m 0644 rubygems/version_option.rb
/Library/Ruby/Site/1.8/rubygems/version_option.rb
install -c -m 0644 rubygems.rb /Library/Ruby/Site/1.8/rubygems.rb
install -c -m 0644 ubygems.rb /Library/Ruby/Site/1.8/ubygems.rb
cp gem /tmp/gem
install -c -m 0755 /tmp/gem
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/gem
rm /tmp/gem
cp update_rubygems /tmp/update_rubygems
install -c -m 0755 /tmp/update_rubygems
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/update_rubygems
rm /tmp/update_rubygems
rm /Library/Ruby/Gems/1.8/source_cache
Removing old RubyGems RDoc and ri…
rm -rf /Library/Ruby/Gems/1.8/doc/rubygems-1.0.1
Installing rubygems-1.0.1 ri into
/Library/Ruby/Gems/1.8/doc/rubygems-1.0.1/ri…
Installing rubygems-1.0.1 rdoc into
/Library/Ruby/Gems/1.8/doc/rubygems-1.0.1/rdoc…
As of RubyGems 0.8.0, library stubs are no longer needed.
Searching $LOAD_PATH for stubs to optionally delete (may take a
while)…
…done.
No library stubs found.
RubyGems system software updated

but installing wxruby shows me the same problem:

$ sudo gem install wxruby -r
Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR: could not find wxruby locally or in a repository

and strangely the gem version seems not to have changed:

$ gem --version
1.0.1

I add that I’m not behind a firewall (but I have the standard OSX
protections), and I never experimented problems with internet.

For now you can try downloading the gem directly and installing it
from the local download.

http://rubyforge.org/frs/?group_id=35

wxruby-1.9.2-i686-darwin8.8.2.gem (Intel)
wxruby-1.9.2-powerpc-darwin8.10.0.gem (PowerPC)

The gem system sure seems to have gotten flaky over the last year or so.

Sean

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs