Cannot install ruby-fcgi on windows 2000

As said in the title I am using windows 2000 and cannot get ruby-fcgi
0.8.7or
0.8.6 to install. Hopefully someone has gotten this working by now. In
the
mailing list the only thing I could find was unanswered posts from 2
years
ago.

TIA

0.8.7 gives:

C:\ruby-fcgi>ruby install.rb config
—> lib
<— lib
—> ext
—> ext/fcgi
c:/ruby/bin/ruby C:/ruby-fcgi/ext/fcgi/extconf.rb
install.rb:656:in command': system("c:\\ruby\\bin\\ruby" "C:/ruby-fcgi/ext/fcgi/extconf.rb") failed (RuntimeError) from install.rb:661:inruby’
from install.rb:1237:in extconf' from install.rb:1233:inconfig_dir_ext’
from install.rb:1498:in traverse' from install.rb:1515:indive_into’
from install.rb:1496:in traverse' from install.rb:1500:intraverse’
from install.rb:1499:in traverse' from install.rb:1515:indive_into’
from install.rb:1496:in traverse' from install.rb:1490:inexec_task_traverse’
from install.rb:1485:in exec_task_traverse' from install.rb:1220:inexec_config’
from install.rb:991:in exec_config' from install.rb:827:ininvoke’
from install.rb:774:in `invoke’
from install.rb:1544

C:\ruby-fcgi>

0.8.6 an error that I thought could be fixed by having fastcgiapp.h but
no
matter where it is place the same error occurs and trying to enter an
option
with the path seems to only give option not found errors.

C:\ruby-fcgi-0.8.6>ruby install.rb config
install.rb: entering config phase…
—> lib
<— lib
—> ext
—> ext/fcgi
c:/ruby/bin/ruby C:/ruby-fcgi-0.8.6/ext/fcgi/extconf.rb
checking for fcgiapp.h… no
checking for fastcgi/fcgiapp.h… no
*** C:/ruby-fcgi-0.8.6/ext/fcgi/extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–srcdir=C:/ruby-fcgi-0.8.6/ext/fcgi
–curdir
–ruby=c:/ruby/bin/ruby
–with-fcgi-dir
–without-fcgi-dir
–with-fcgi-include
–without-fcgi-include=${fcgi-dir}/include
–with-fcgi-lib
–without-fcgi-lib=${fcgi-dir}/lib
config failed
'system c:/ruby/bin/ruby C:/ruby-fcgi-0.8.6/ext/fcgi/extconf.rb ’ failed
try ‘ruby install.rb --help’ for usage

C:\ruby-fcgi-0.8.6>

Here’s the latest try with the same result. The path to a needed file is
not
being picked up even though now I seem to be using the right options.

c:>cd ruby-fcgi-0.8.6

C:\ruby-fcgi-0.8.6>ruby install.rb config
–with-fcgi-include=C:\fcgi-2.4.0–with-fcgi-lib=C:
config: unknown option --with-fcgi-include=C:\fcgi-2.4.0
try ‘ruby install.rb --help’ for usage

C:\ruby-fcgi-0.8.6>ruby install.rb config --with-fcgi-include=C:\fcgi-
2.4.0\include --with-fcgi-lib=C:\fcgi-2.4.0\libfcgi
config: unknown option --with-fcgi-include=C:\fcgi-2.4.0\include
try ‘ruby install.rb --help’ for usage

C:\ruby-fcgi-0.8.6>ruby install.rb --help

Usage:
ruby install.rb
ruby install.rb [] []

Global options:
-q,–quiet suppress message outputs
–verbose output messages verbosely
-h,–help print this message
-v,–version print version and quit
–copyright print copyright and quit

Tasks:
config saves your configurations
show shows current configuration
setup compiles extention or else
install installs files
clean does `make clean’ for each extention

Options for config:
–prefix=path path prefix of target environment [c:/ruby]
–std-ruby=path the directory for standard ruby libraries
[$prefix/lib/ruby/1.8]
–site-ruby-common=path the directory for version-independent
non-standard
ruby libraries [$prefix/lib/ruby/site_ruby]
–site-ruby=path the directory for non-standard ruby libraries
[$prefix/lib/ruby/site_ruby/1.8]
–bin-dir=path the directory for commands [$prefix/bin]
–rb-dir=path the directory for ruby scripts [$site-ruby]
–so-dir=path the directory for ruby extentions
[$prefix/lib/ruby/site_ruby/1.8/i386-msvcrt]
–data-dir=path the directory for shared data [$prefix/share]
–ruby-path=path path to set to #! line [c:/ruby/bin/ruby]
–ruby-prog=name the ruby program using for installation
[c:/ruby/bin/ruby]
–make-prog=name the make program to compile ruby extentions
[make]
–without-ext does not compile/install ruby extentions [no]
–rbconfig=path your rbconfig.rb to load [running ruby’s]

Options for install:
–no-harm only display what to do if given [off]

C:\ruby-fcgi-0.8.6>cd…

C:>ruby c:\ruby-fcgi-0.8.6\ext\fcgi\extconf.rb
–with-fcgi-include=c:\fcgi-
2.4.0\include --with-fcgi-lib=c:\fcgi-2.4.0\libfcgi
checking for fcgiapp.h… no
checking for fastcgi/fcgiapp.h… no
*** c:/ruby-fcgi-0.8.6/ext/fcgi/extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–srcdir=c:/ruby-fcgi-0.8.6/ext/fcgi
–curdir
–ruby=c:/ruby/bin/ruby
–with-fcgi-dir
–without-fcgi-dir
–with-fcgi-include=${fcgi-dir}/include
–with-fcgi-lib=${fcgi-dir}/lib

C:>ruby c:/ruby-fcgi-0.8.6/ext/fcgi/extconf.rb
–with-fcgi-include=c:/fcgi-
2.4.0/include --with-fcgi-lib=c:/fcgi-2.4.0/libfcgi
checking for fcgiapp.h… no
checking for fastcgi/fcgiapp.h… no
*** c:/ruby-fcgi-0.8.6/ext/fcgi/extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–srcdir=c:/ruby-fcgi-0.8.6/ext/fcgi
–curdir
–ruby=c:/ruby/bin/ruby
–with-fcgi-dir
–without-fcgi-dir
–with-fcgi-include=${fcgi-dir}/include
–with-fcgi-lib=${fcgi-dir}/lib

C:>

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs