Cannot install plugins

I used to be able to install plugins, but for some reason the plugins
system has stopped working for me.

If I try to install something like comatose, I get the following:

C:\rails\BAct>ruby script/plugin source
http://mattmccray.com/svn/rails/plugins
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:422:in
remove_const': cannot remove Object::OPT_TABLE (NameError) from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:422:insend’
from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:422:in
remove_constant' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:368:innew_constants_in’
from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:368:in
each' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:368:innew_constants_in’
from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:in
`require’
from script/plugin:3

I get the same set of errors (exactly) for almost any plugins command I
try.

I am using Windows XP, rails 1.2.3, and have updated all of my gems.

Anybody know what I am doing wrong, or how to fix this?

– Will Merrell

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs