Cannot get jquery to work

<%= javascript_include_tag “jquery.js” %>

I want to add class to table tag using following command inside
script tag.

CSS has all the tree class declared
.odd {
background-color: #fcc;

.even {
background-color: #cef;

.table-heading {
font-size: 12px;

CSS is linked properly and if I add class manually I can see the
stylesheet applied to the page.

But I cannot get the alert neither I can see the class in


I am a newbie to rails.
any help is appreciated.

Thanks in advance

On Wed, Apr 29, 2009 at 11:39 PM, Anil [email protected] wrote:

<%= javascript_include_tag “jquery.js” %>

Shouldn’t that be <%= javascript_include_tag ‘jquery’ %>

You could probably easily discover whether your jquery file is being
loaded by using Firebug, btw…


Hassan S. ------------------------ [email protected]

Thanks Hassan S.,

The File is loaded correctly.
And I tried both <%= javascript_include_tag ‘jquery’ %> <%=
javascript_include_tag “jquery.js” %>
And both load the file correctly.

Moreover I can see the JavaScript (JQuery.js) loaded using firebug.

Still No luck.


On Apr 30, 7:14 am, Hassan S. [email protected]

On Thu, Apr 30, 2009 at 9:58 AM, Anil [email protected] wrote:

Oh, wait –

(document).ready( function() {


// not THE problem, but invalid otherwise $(document).ready( ... Try that... -- Hassan S. ------------------------ [email protected]

yeah, if you still have javascript_include_tag :defaults, prototype
will still get loaded

If you want to keep prototype loaded though (to take advantage of
Rails builtin AJAX functionality for example), will be of

The problem was the case of addClass.
Changing addclass to addClass did the trick.
Thank you very much guys for all your help.


Are you sure you are not including prototype.js?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs