Cannot Freeze Gems

I am facing the following issue since Rails 2 was released. I need to
freeze 1.2.6 and I can’t. The error messages are below. For the
record, the rails application works fine via Mongrel. I just can’t
freeze the gems. These are on Fedora 7.

$ rake rails:freeze:gems VERSION=1.2.6 --trace
(in /work/aptana/workspace/avls)
** Invoke rails:freeze:gems (first_time)
** Execute rails:freeze:gems
Freezing to the gems for Rails 1.2.6
rake aborted!
uninitialized constant Gem::GemRunner
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:2028:in
const_missing' /usr/lib64/ruby/gems/1.8/gems/rails-1.2.6/lib/tasks/framework.rake:26 /usr/lib64/ruby/gems/1.8/gems/rails-1.2.6/lib/tasks/framework.rake: 25:ineach’
/usr/lib64/ruby/gems/1.8/gems/rails-1.2.6/lib/tasks/framework.rake:25
/usr/lib/ruby/1.8/fileutils.rb:121:in chdir' /usr/lib/ruby/1.8/fileutils.rb:121:inchdir’
/usr/lib64/ruby/gems/1.8/gems/rails-1.2.6/lib/tasks/framework.rake:24
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in call' /usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:inexecute’
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in each' /usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:inexecute’
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:362:in invoke' /usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:insynchronize’
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in invoke' /usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:intop_level’
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in each' /usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:intop_level’
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in
standard_exception_handling' /usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1733:intop_level’
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1711:in run' /usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:instandard_exception_handling’
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1708:in run' /usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/bin/rake:7 /usr/bin/rake:16:inload’
/usr/bin/rake:16


moreover, I get the following odd errors. they were fine before

gem --version

0.9.5

gem install rails --version=1.2.6

Successfully installed rails-1.2.6
1 gem installed

rails --version

/usr/lib/ruby/site_ruby/1.8/rubygems.rb:377:in
report_activate_error': Could not find RubyGem activeresource (= 2.0.1) (Gem::LoadError) from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:309:inactivate’
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:335:in activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:334:ineach’
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:334:in activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:76:inactive_gem_with_options’
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:50:in `gem’
from /usr/bin/rails:18

This is a known issue and it is fixed in Rails edge (change set 8336).

Regards,
Nicolai

Thanks Nicolai. Can we expect a Rails 1.2.6.x or 1.2.7 that addresses
this problem by the end of December? I assume when you say edge, it
is for the 2.0.x code base.

Regards,
Mukund

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs