Cannot add ticket on Trac

This is so frustrating… no matter what I do, the Typo trac rejects
any ticket I try to add as spam. Grr! I’d love to report my
Textile/Markdown problem officially, but I can’t…

Huh, that’s odd. Perhaps you could post your problem here, and if
it’s legit someone else could add the ticket for you?

On 7/5/06, Kevin B. [email protected] wrote:

Huh, that’s odd. Perhaps you could post your problem here, and if
it’s legit someone else could add the ticket for you?

Well, it’s worth a shot. Here’s my problem:

With the current trunk, when I have Textile selected as the text
filter to apply to a message, Markdown is applied as well. I had an
example on my blog, but now, since I changed the default text filter
to Markdown, it appears in Markdown only and I cannot save a change
the text filter on the “edit entry” page. To check it out, someone
else will have to try it.

I have to admit, I’m getting pretty frustrated with Typo.

Actually, redcloth has a limited ability to handle markdown formatting.
So
we might accidentally be running redcloth in textile+markdown mode.

Scott

That’s a, um, pretty bizarre problem. I can’t imagine how that would
possibly happen, since only one formatting style (markdown vs
textile) is allowed in a text filter. Plus, it should be perfectly
fine to change the textfilter from the edit page.

Can you try something for me? Edit
components/plugins/textfilters/textile_controller.rb and change
RedCloth.newto RedCloth::
Textile.new. Then tell Typo to rebuild all of your cached HTML and see
what
happens. It should fix your problem.

Now, should this fix go into the trunk or not? It’ll change
long-standing
behavior, and may break some people’s formatting. It’s a bug, but it’s
an
old bug. Opinions?

Scott

On 7/5/06, Kevin B. [email protected] wrote:

That’s a, um, pretty bizarre problem. I can’t imagine how that would
possibly happen, since only one formatting style (markdown vs
textile) is allowed in a text filter. Plus, it should be perfectly
fine to change the textfilter from the edit page.

I just tried to change the textfilter on an existing entry in my Typo
install, both with Firefox and with Internet Explorer, with and
without logging out of Typo after editing and storing the entry, and
none of those actions changed the textfilter.

(Sorry, that sent before I was finished)

Would it be possible to just add “Textile+Markdown” in the text filter
menu?
I really haven’t looked to see how text filters work, so I have no idea
if
this is even possible. It seems like it couldn’t take too much.

That being said, I completely understand if it’s better for everyone
else to
just switch and use pure Textile. I realize I’m probably in the minority
here. As long as I can switch it back, I have no qualms. :slight_smile:

|| Dean

On 7/6/06, Scott L. [email protected] wrote:

Now, should this fix go into the trunk or not? It’ll change long-standing
behavior, and may break some people’s formatting. It’s a bug, but it’s an
old bug. Opinions?

I noticed this behavior a while ago[1], and frankly, I love it. I much
prefer Markdown’s linking syntax with Textile’s formatting.

[1]:<http://zenchic.net/articles/2006/03/11/redcloth-supports-markdown-links

On 7/6/06, Scott L. [email protected] wrote:

Can you try something for me? Edit
components/plugins/textfilters/textile_controller.rb and
change RedCloth.new to RedCloth::Textile.new. Then tell Typo to rebuild all
of your cached HTML and see what happens. It should fix your problem.

That didn’t work for me; instead, it removed all formatting from
entries. Using irb to try this I get “uninitialized constant
RedCloth::Textile.new”.

This, however, does work:

RedCloth.new(text).to_html(:textile)

Now, should this fix go into the trunk or not? It’ll change long-standing
behavior, and may break some people’s formatting. It’s a bug, but it’s an
old bug. Opinions?

As a new user, I can tell you I was surprised to find this happening
– and it didn’t happen when I was running the
stable-2.6-with-frozen-Rails release. Which, on looking, used code
very similar to my fix, above, to render textile:

txt = RedCloth.new(txt, restrictions).to_html(:textile)

I vote “yeah, it should go in, with an option to apply both Textile
and Markdown for those who want it”.

2.6 did Textile only? Okay, I’m probably going to revert back to the
old
behavior for now, and add a new filter that handles textile+markdown.

Scott

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs