Cannot Access new USRP2 from Ubuntu 9.10

Dear all,

I have successfully installed the binary for GnuRadio 3.2.2-1 and
gnuradio-compaion on Ubuntu 9.10.

I have a new USRP2 Rev 4.0 with TVRX. The SD card is in, and lights D
and F
are on.

I followed guidelines on USRP2UserFAQ (and reviewed previous posts), but
am
not able to connect to USRP2. I am connecting using a Intel 82566
Gigabit
card with PCIe on a Lenovo T61 laptop. I run the following as root:

$find_usrps
I get: No USRP2 found.

When I run:
$ usrp2_fft.py

I get:

Traceback (most recent call last):
File “/usr/bin/usrp2_fft.py”, line 273, in
main ()
File “/usr/bin/usrp2_fft.py”, line 269, in main
app = stdgui2.stdapp(app_top_block, “USRP2 FFT”, nstatus=1)
File “/usr/lib/python2.6/dist-packages/gnuradio/wxgui/stdgui2.py”,
line
36, in init
wx.App.init (self, redirect=False)
File
“/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py”,
line 7978, in init
self._BootstrapApp()
File
“/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py”,
line 7552, in _BootstrapApp
return core.PyApp__BootstrapApp(*args, **kwargs)
File “/usr/lib/python2.6/dist-packages/gnuradio/wxgui/stdgui2.py”,
line
39, in OnInit
frame = stdframe (self.top_block_maker, self.title, self._nstatus)
File “/usr/lib/python2.6/dist-packages/gnuradio/wxgui/stdgui2.py”,
line
60, in init
self.panel = stdpanel (self, self, top_block_maker)
File “/usr/lib/python2.6/dist-packages/gnuradio/wxgui/stdgui2.py”,
line
81, in init
self.top_block = top_block_maker (frame, self, vbox, sys.argv)
File “/usr/bin/usrp2_fft.py”, line 70, in init
self.u = usrp2.source_32fc(options.interface, options.mac_addr)
File “/usr/lib/python2.6/dist-packages/gnuradio/usrp2.py”, line 644,
in
source_32fc
return _usrp2.source_32fc(*args, **kwargs)
RuntimeError: No USRPs found on interface eth0


I tried the same things on a different PC with the same OS and a
different
gigabit ethernet card, but get the exact same results.
Can someone please help me out? I am sure the cable is also working. Can
the
ethernet interface on USRP2 be defective?

Thanks,
Omid

I usually run find_usrps as root:

sudo find_usrps

also, what is the device name of your gig-e card? If it’s not eth0
you have to specify the device (I think), for example:

sudo find_usrps -e eth1

I wouldn’t be surprised if your laptop’s default ethernet port is not
gig-e, and is eth0.

Thanks for the prompt response Tom.

I was running as root previously too. I tried again, no difference, I
get:
“No USRP2 found.”

I am sure it is eth0. Just to be safe, I tried others (e.g. sudo
find_usrps
-e eth1) and I get:
“eth1: SIOCGIFINDEX: No such device
No USRP2 found.”

Could it be something related to Ubuntu 9.10?
How can I make sure the interface on USRP2 is not defective?

Thanks,
Omid

run wireshark, you should see packets going out.

If you do not see packets going out, then it is a gnuradio installation
or usage problem.

If you see packets going out but do not see reply packets, make sure
that your usrp2 firmware is up to date with your gnuradio install.

-Josh

Thanks for the suggestion. I tried wireshark. I didn’t see any packages
going out when I called “sudo find_usrps”. How do I make sure gnuradio
is
installed properly? The installation seemed to go smoothly, and I am
able to
run grc (gnuradio-companion).

Thanks,
Omid

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs